Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Aggiornamento automatico delle address list di spammer

#1
In questa guida vi mostro come aggiornare automaticamente le address list nel nostro mikrotik in modo da eliminare ogni tentativo di spammer o cracker che voglia accedere alla RouterBoard
[hide]
OpenBL
Codice:
# Script which will download the drop list as a text file
/system script add name="Download_openbl" source={
/tool fetch url="http://IpDelServer/openbl.rsc" mode=http;
:log info "Downloaded openbl.rsc";
}

# Script which will Remove old Begone list and add new one
/system script add name="Replace_openbl" source={
:foreach i in=[/ip firewall address-list find ] do={
:if ( [/ip firewall address-list get $i comment] = "OpenBL" ) do={
/ip firewall address-list remove $i
}
}
/import file-name=openbl.rsc;
:log info "Removal old openbl and add new";
}

# Schedule the download and application of the openbl list
/system scheduler add comment="Download openbl list" interval=7d name="DownloadBegoneList" on-event=Download_openbl start-date=jan/01/1970 start-time=01:05:00
/system scheduler add comment="Apply openbl List" interval=7d name="InstallBegoneList" on-event=Replace_openbl start-date=jan/01/1970 start-time=01:15:00

SpamHaus

Codice:
# Script which will download the drop list as a text file
/system script add name="Download_spamhaus" source={
/tool fetch url="http://IpDelServer/spamhaus.rsc" mode=http;
:log info "Downloaded spamhaus.rsc";
}

# Script which will Remove old Begone list and add new one
/system script add name="Replace_spamhaus" source={
:foreach i in=[/ip firewall address-list find ] do={
:if ( [/ip firewall address-list get $i comment] = "SpamHaus" ) do={
/ip firewall address-list remove $i
}
}
/import file-name=spamhaus.rsc;
:log info "Removal old openbl and add new";
}

# Schedule the download and application of the spamhaus list
/system scheduler add comment="Download spamnaus list" interval=7d name="DownloadSpamhausList" on-event=Download_spamhaus start-date=jan/01/1970 start-time=02:02:00
/system scheduler add comment="Apply spamnaus List" interval=7d name="InstallSpamhausList" on-event=Replace_spamhaus start-date=jan/01/1970 start-time=02:12:00

DShield

Codice:
# Script which will download the drop list as a text file
/system script add name="Download_dshield" source={
/tool fetch url="http://IpDelServer/dshield.rsc" mode=http;
:log info "Downloaded dshield.rsc";
}

# Script which will Remove old Begone list and add new one
/system script add name="Replace_dshield" source={
:foreach i in=[/ip firewall address-list find ] do={
:if ( [/ip firewall address-list get $i comment] = "DShield" ) do={
/ip firewall address-list remove $i
}
}
/import file-name=dshield.rsc;
:log info "Removal old dshield and add new";
}

# Schedule the download and application of the dshield list
/system scheduler add comment="Download dshield list" interval=7d name="DownloadDShieldList" on-event=Download_dshield start-date=jan/01/1970 start-time=02:42:00
/system scheduler add comment="Apply dshield List" interval=7d name="InstallDShieldList" on-event=Replace_dshield start-date=jan/01/1970 start-time=02:52:00

e per finire

Codice:
/ip firewall filter
add action=drop chain=forward comment=Drop Address List  disabled=no src-address-list=blacklist

Come generare le address list:

questo script va fatto girare su una macchina server con Linux a cui le varie RouterBoard si collegheranno

Codice:
#!/bin/sh
saveTo=/var/www
now=$(date);
echo "# Generated on $now" > $saveTo/dshield.rsc
echo "/ip firewall address-list" >> $saveTo/dshield.rsc
wget -q -O - http://feeds.dshield.org/block.txt | awk --posix '/^[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.0\t/ { print "add list=blacklist address=" $1 "/24 comment=DShield";}' >> $saveTo/dshield.rsc

echo "# Generated by Joshaven Potter on $now" > $saveTo/spamhaus.rsc
echo "/ip firewall address-list" >> $saveTo/spamhaus.rsc
wget -q -O - http://www.spamhaus.org/drop/drop.lasso | awk --posix '/[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\// { print "add list=blacklist address=" $1 " comment=SpamHaus";}' >> $saveTo/spamhaus.rsc

echo "# Generated by Joshaven Potter on $now" > $saveTo/openbl.rsc
echo "/ip firewall address-list" >> $saveTo/openbl.rsc
wget -q -O - http://www.openbl.org/lists/base_30days.txt.gz | gunzip | awk --posix '/^[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}/ { print "add list=blacklist address=" $1 " comment=OpenBL";}' >> $saveTo/openbl.rsc
[/hide]
Cita messaggio

#2
Puoi spiegare nel dettaglio la funzione di questo scheduler-script e se puo essere aggiunto alla seguente filter rule:

"/ip firewall filter

add chain=forward protocol=tcp dst-port=25 src-address-list=spammer
action=drop comment="BLOCK SPAMMERS OR INFECTED USERS"

add chain=forward protocol=tcp dst-port=25 connection-limit=30,32 limit=50,5 action=add-src-to-address-list
address-list=spammer address-list-timeout=1d comment="Detect and add-list SMTP virus or spammers"
"
Inoltre lo script da far girare su server linux è necessario?
Cita messaggio

#3
(14-12-2014, 23:19)giallopaperino Ha scritto: Puoi spiegare nel dettaglio la funzione di questo scheduler-script e se puo essere aggiunto alla seguente filter rule:

"/ip firewall filter

add chain=forward protocol=tcp dst-port=25 src-address-list=spammer
action=drop comment="BLOCK SPAMMERS OR INFECTED USERS"

add chain=forward protocol=tcp dst-port=25 connection-limit=30,32 limit=50,5 action=add-src-to-address-list
address-list=spammer address-list-timeout=1d comment="Detect and add-list SMTP virus or spammers"
"
Inoltre lo script da far girare su server linux è necessario?
La parte dello script che hai segnalato serve a bloccare un qualsiasi utente nella rete che spamma.
Perché parli di server Linux? ?

sent from wifi device using Tapatalk Smile
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#4
Scusa mi sono espresso male. Intendevo dire quello del post di hamtarociaoo ad inizio thread. Quello che ho segnalato è già inserito nella mia RouterBoard. Chiedevo se gli script scheduler di hamtarociaoo possono integrare quelli segnalati da me. Inoltre pensavo che servissero per bloccare lo spam proveniente dalla wan , non dalla LAN. Per cui su una LAN domestica potrebbero non servire?
Il server Linux a cui facevo riferimento è scritto nel post di hamtarociaoo .
Cita messaggio

#5
(15-12-2014, 07:41)giallopaperino Ha scritto: Scusa mi sono espresso male. Intendevo dire quello del post di hamtarociaoo ad inizio thread. Quello che ho segnalato è già inserito nella mia RouterBoard. Chiedevo se gli script scheduler di hamtarociaoo possono integrare quelli segnalati da me. Inoltre pensavo che servissero per bloccare lo spam proveniente dalla wan , non dalla LAN. Per cui su una LAN domestica potrebbero non servire?
Il server Linux a cui facevo riferimento è scritto nel post di hamtarociaoo .

Lo Spam proveniente dalla wan non si può bloccare, quello proveniente dalla lan si blocca per come ti é stato detto.
Non trovo dove si parla di server Linux me lo posti per favore ?

sent from wifi device using Tapatalk Smile
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#6
Ecco:
Citazione:
"Come generare le address list:



questo script va fatto girare su una macchina server con Linux a cui le varie RouterBoard si collegheranno



#!/bin/sh
saveTo=/var/www
now=$(date);
echo \"# Generated on $now\" > $saveTo/dshield.rsc
echo \"/ip firewall address-list\" >> $saveTo/dshield.rsc
wget -q -O - http://feeds.dshield.org/block.txt | awk --posix '/^[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.0\t/ { print \"add list=blacklist address=\" $1 \"/24 comment=DShield\";}' >> $saveTo/dshield.rsc

echo \"# Generated by Joshaven Potter on $now\" > $saveTo/spamhaus.rsc
echo \"/ip firewall address-list\" >> $saveTo/spamhaus.rsc
wget -q -O - http://www.spamhaus.org/drop/drop.lasso | awk --posix '/[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\// { print \"add list=blacklist address=\" $1 \" comment=SpamHaus\";}' >> $saveTo/spamhaus.rsc

echo \"# Generated by Joshaven Potter on $now\" > $saveTo/openbl.rsc
echo \"/ip firewall address-list\" >> $saveTo/openbl.rsc
wget -q -O - http://www.openbl.org/lists/base_30days.txt.gz | gunzip | awk --posix '/^[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}/ { print \"add list=blacklist address=\" $1 \" comment=OpenBL\";}' >> $saveTo/openbl.rsc
"
Cita messaggio

#7
Ma no

sent from wifi device using Tapatalk Smile
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#8
Ti riporto quello scritto da hamtarociaoo. Comunque secondo me in una LAN casalinga, seppur medio grande, ha poco senso.
Cita messaggio

#9
(15-12-2014, 12:27)giallopaperino Ha scritto: Ti riporto quello scritto da hamtarociaoo. Comunque secondo me in una LAN casalinga, seppur medio grande, ha poco senso.
Invece ha senso e come

sent from wifi device using Tapatalk Smile
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#10
Sicuramente parlo da poco esperto, ma in casa mia ci sono solo i miei pc collegati via cavo e diverse periferiche wifi mie e di mia moglie. Il wifi è criptato. Tu dici che il rischio ci possa essere da qualcuno che potrebbe bucare il wifi?
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  [Mikrotik] Firewall: Address List hamtarociaoo 0 1'952 12-09-2013, 18:44
Ultimo messaggio: hamtarociaoo

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.