Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Automated Upgrade/Downgrade script V3.9+

#1
Information 
We use this script on MT-routers to roll out upgrades or downgrades to all platforms across our whole network. The new system updates can sit on any FTP server. For this to function correctly you need a txt file "CurrentVersion.txt" in the same FTP directory as your RouterOS package files. This file can be created on your RouterOS through the console: 
Codice:
/file print file="CurrentVersion";
/file set CurrentVersion.txt content="3.9";
The Automatic script: 
Codice:
:local lMajor

Codice:
:local lMinor

Codice:
:local vMajor

Codice:
:local vMinor

Codice:
:local ftpserver "YOUR FTP SERVER"

Codice:
:local ftppass "FTP SERVER PASS"

Codice:
:local ftpuser "YOUR FTP USER"

Codice:
:local platform [/system resource get architecture-name]

Codice:
:local myVer [/system resource get version]


Codice:
/tool fetch address="" path="CurrentVersion.txt" user="$ftpuser" password="$ftppass" mode=ftp;


Codice:
:local lVer [/file get CurrentVersion.txt content]


Codice:
:for i from=0 to=([:len $myVer] - 1) do={  

Codice:
    :if ( [:pick $myVer $i] = ".") do={

Codice:
        :set vMajor [:tonum [:pick $myVer 0 $i]];

Codice:
        :set vMinor [:tonum [:pick $myVer ($i + 1) [:len $myVer]]]

Codice:
    }

Codice:
}


Codice:
:delay 5s;

Codice:
:for i from=0 to=([:len $lVer] - 1) do={  

Codice:
    :if ( [:pick $lVer $i] = ".") do={

Codice:
        :set lMajor [:tonum [:pick $lVer 0 $i]];

Codice:
        :set lMinor [:tonum [:pick $lVer ($i + 1) [:len $lVer]]]

Codice:
    }

Codice:
}


Codice:
:if ([$myVer] = $lVer) do={ :nothing } else={ :local pckgName ("routeros-" . $platform . "-" . $lMajor .

Codice:
"." . $lMinor . ".npk"); /tool fetch address="$ftpserver" user="$ftpuser" password="$ftppass" mode=ftp

Codice:
path="$pckgName"; :if ([$myVer] > $lVer) do={ :log warning "Downgrade Requested"; /system package downgrade }

Codice:
else={ :log warning "Upgrade Requested"; /system reboot } }

You can run this at regular intervals from the scheduler.
This should be tested in your environment with your variables and used at your own risk!
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Exclamation Script: Notifica sovraccarico CPU hamtarociaoo 1 904 10-09-2016, 01:18
Ultimo messaggio: hunte88
Information [Mikrotik] Semi-Automating CPE ROS/Firmware/script updates and setting changes berryberry 0 712 17-06-2015, 11:54
Ultimo messaggio: berryberry
Information [Mikrotik] SXT 5HnD Alignment Script berryberry 0 942 17-06-2015, 11:47
Ultimo messaggio: berryberry
Information [Mikrotik] Yet Another Alignment Script With LEDs And Sound berryberry 0 985 17-06-2015, 11:07
Ultimo messaggio: berryberry
  [Mikrotik] Improved auto upgrade script v3.X berryberry 0 592 17-06-2015, 10:53
Ultimo messaggio: berryberry
Information [Mikrotik] Auto upgrade script V3.x berryberry 0 368 17-06-2015, 10:34
Ultimo messaggio: berryberry
Information [Mikrotik] Centralized Automated Backups via Email with Procmail and Perl berryberry 0 499 16-06-2015, 11:49
Ultimo messaggio: berryberry
Information [Mikrotik] Monitor logs, send email alert / run script berryberry 0 716 16-06-2015, 10:55
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience /Monitoring -ECMP Failover Script berryberry 0 530 16-06-2015, 09:45
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience/Monitoring- Monitoring Script berryberry 0 417 16-06-2015, 08:56
Ultimo messaggio: berryberry

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.