Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Firewall: Layer 7

#1
Il protocollo layer7 è un metodo di ricerca per flussi ICMP / TCP / UDP. Il funzionamento del layer7 è molto semplice: analizza i primi 10 pacchetti della connessione o primi 2 KB della connessione ed analizza i dati raccolti. Se i dati raccolti non corrispondono a quello ricercato il "marcatore" non analizza più e la memoria allocata viene liberata, a questo punto il protocollo viene considerato come sconosciuto. Anche in questo caso un umero eccessivo di connessioni aumenta considerevolmente il numero di risorse impegnate nella routerboard. Per evitare questo consumo eccessivo è consigliato aggiungere regolari "marcatori" nel firewall per ridurre la quantità di dati passati che vengono passati al filtro del Layer-7.
[hide]
Codice:
Il protocollo layer7 è case sensitive

Proprietà:



Property Description
name (string; Default: ) Descriptive name of l7 pattern used by configuration in firewall rules.
regexp (string; Default) POSIX compliant regular expression used to match pattern.

Esempio:

La prima cosa da fare è aggiungere delle regular expression per definire il protocollo RDP
Codice:
/ip firewall filter

# add few known protocols to reduce mem usage
add action=accept chain=forward comment="" disabled=no port=80 protocol=tcp
add action=accept chain=forward comment="" disabled=no port=443 protocol=tcp

# add l7 matcher
add action=accept chain=forward comment="" disabled=no layer7-protocol=\
    rdp protocol=tcp
Come è possibile vedere, sono state aggiunte delle regole per diminuire il numero di risorse occupate sulla routerboard.
[/hide]
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  [Mikrotik] Basic Firewall hamtarociaoo 21 8'135 16-08-2016, 15:47
Ultimo messaggio: tecnofan
Bug un altro esempio di configurazione del firewall hamtarociaoo 23 4'674 06-02-2015, 08:15
Ultimo messaggio: kikko
  Esempio sulla configurazione del firewall di RouterOS kikko 23 7'695 22-02-2014, 16:57
Ultimo messaggio: kikko
  [Mikrotik] Firewall: Mangle hamtarociaoo 17 10'090 27-09-2013, 16:28
Ultimo messaggio: kikko
  [Mikrotik] Firewall: Address List hamtarociaoo 0 1'966 12-09-2013, 18:44
Ultimo messaggio: hamtarociaoo
  [Mikrotik] Firewall: Connection tracking hamtarociaoo 0 3'726 12-09-2013, 18:42
Ultimo messaggio: hamtarociaoo
Information [Mikrotik] RouterOS: il firewall hamtarociaoo 0 4'136 12-09-2013, 18:34
Ultimo messaggio: hamtarociaoo

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.