Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Firewall: Mangle

#1
Il mangle è un tipo di "mark" di pacchetti usato per successivi processi di filtraggio. Molte altre sezioni del routerOS fanno uso di questi pacchetti "marcati" come le code (queue, il nat oppure il routing). Il mangle identifica un pacchetto in base al suo "mark" e lo processa seconde delle regole che l'utente stabilisce. Osserviamo che il "mark" del pacchetto avviene solamente attraverso il router questo vuol dire che nessuna informazione sul mark avviene all'esterno del router stesso.
[hide]
Proprietà:

Property Description
action (action name; Default: accept) Action to take if packet is matched by the rule:
  • accept - accept the packet. Packet is not passed to next firewall rule.
  • add-dst-to-address-list - add destination address to Address list specified by address-list parameter
  • add-src-to-address-list - add source address to
    address-list parameter
  • change-dscp - change Differentiated Services Code Point (DSCP) field value specified by the new-dscp parameter
  • change-mss - change Maximum Segment Size field value of the packet to a value specified by the new-mss parameter
  • change-ttl - change Time to Live field value of the packet to a value specified by the new-ttl parameter
  • jump - jump to the user defined chain specified by the value of jump-target parameter
  • log - add a message to the system log containing following data: in-interface, out-interface, src-mac, protocol, src-ip:port->dst-ip:port and length of the packet. After packet is matched it is passed to next rule in the list, similar as passthrough
  • mark-connection - place a mark specified by the new-connection-mark parameter on the entire connection that matches the rule
  • mark-packet - place a mark specified by the new-packet-mark parameter on a packet that matches the rule
  • mark-routing - place a mark specified by the new-routing-mark parameter on a packet. This kind of marks is used for policy routing purposes only
  • passthrough - ignore this rule and go to next one (useful for statistics).
  • return - pass control back to the chain from where the jump took place
  • set-priority - set priority speciefied by the new-priority parameter on the packets sent out through a link that is capable of transporting priority (VLAN or WMM-enabled wireless interface).
  • strip-ipv4-options - strip IPv4 option fields from IP header.
address-list (string; Default: ) Name of the address list to be used. Applicable if action is add-dst-to-address-list or add-src-to-address-list
address-list-timeout (time; Default: 00:00:00) Time interval after which the address will be removed from the address list specified by address-list parameter. Used in conjunction with add-dst-to-address-list or add-src-to-address-list actions
Value of 00:00:00 will leave the address in the address list forever
chain (name; Default: ) Specifies to which chain rule will be added. If the input does not match the name of an already defined chain, a new chain will be created.
comment (string; Default: ) Descriptive comment for the rule.
connection-bytes (integer-integer; Default: ) Matches packets only if a given amount of bytes has been transfered through the particular connection. 0 - means infinity, for example connection-bytes=2000000-0 means that the rule matches if more than 2MB has been transfered through the relevant connection
connection-limit (integer,netmaks; Default: ) Restrict connection limit per address or address block/td>
connection-mark (no-mark | string; Default: ) Matches packets marked via mangle facility with particular connection mark. If no-mark is set, rule will match any unmarked connection.
connection-rate (Integer 0..4294967295; Default: ) Connection Rate is a firewall matcher that allow to capture traffic based on present speed of the connection.
connection-state (estabilished | invalid | new | related; Default: ) Interprets the connection tracking analysis data for a particular packet:
  • established - a packet which belongs to an existing connection
  • invalid - a packet which could not be identified for some reason
  • new - the packet has started a new connection, or otherwise
    associated with a connection which has not seen packets in both directions
  • related - a packet which is related to, but not part of an existing connection, such as ICMP errors or a packet which begins FTP data connection
connection-type (ftp | h323 | irc | pptp | quake3 | sip | tftp; Default: ) Matches packets from related connections based on information from their connection tracking helpers. A relevant connection helper must be enabled under /ip firewall service-port
content (string; Default: ) Match packets that contain specified text
dscp (integer: 0..63; Default: ) Matches DSCP IP header field.
dst-address (IP/netmask | IP range; Default: ) Matches packets which destination is equal to specified IP or falls into specified IP range.
dst-address-list (name; Default: ) Matches destination address of a packet against user-defined address list
dst-address-type (unicast | local | broadcast | multicast; Default: ) Matches destination address type:
  • unicast - IP address used for point to point transmission
  • local - if dst-address is assigned to one of router's interfaces
  • broadcast - packet is sent to all devices in subnet
  • multicast - packet is forwarded to defined group of devices
dst-limit (integer,time,integer,dst-address | dst-port | src-address, time; Default: ) Matches packets within given pps limit. As opposed to the limit matcher, every destination IP address / destination port has it's own limit. Parameters are written in following format: count,time,burst,mode,expire.
  • count - maximum average packet rate measured in packets per time interval
  • time - specifies the time interval in which the packet rate is measured
  • burst - number of packets which are not counted by packet rate
  • mode - the classifier for packet rate limiting
  • expire - specifies interval after which recored ip address /port will be deleted
dst-port (integer[-integer]: 0..65535; Default: ) List of destination port numbers or port number ranges
fragment (yes|no; Default: ) Matches fragmented packets. First (starting) fragment does not count. If connection tracking is enabled there will be no fragments as system automatically assembles every packet
hotspot (auth | from-client | http | local-dst | to-client; Default: )
icmp-options (integer:integer; Default: ) Matches ICMP type:code fileds
in-bridge-port (name; Default: ) Actual interface the packet has entered the router, if incoming interface is bridge
in-interface (name; Default: ) Interface the packet has entered the router
ingress-priority (integer: 0..63; Default) Matches ingress priority of the packet. Priority may be derived from VLAN, WMM or MPLS EXP bit.
ipv4-options (any | loose-source-routing | no-record-route | no-router-alert | no-source-routing | no-timestamp | none | record-route | router-alert | strict-source-routing | timestamp; Default: ) Matches IPv4 header options.
  • any - match packet with at least one of the ipv4 options
  • loose-source-routing - match packets with loose source routing option. This option is used to route the internet datagram based on information supplied by the source
  • no-record-route - match packets with no record route option. This option is used to route the internet datagram based on information supplied by the source
  • no-router-alert - match packets with no router alter option
  • no-source-routing - match packets with no source routing option
  • no-timestamp - match packets with no timestamp option
  • record-route - match packets with record route option
  • router-alert - match packets with router alter option
  • strict-source-routing - match packets with strict source routing option
  • timestamp - match packets with timestamp
jump-target (name; Default) Name of the target chain to jump to. Applicable only if action=jump
layer7-protocol (name; Default: ) Layer7 filter name defined in layer7 protocol menu.
limit (integer,time,integer; Default: ) Matches packets if given pps limit is exceeded. Parameters are written in following format: count,time,burst.
  • count - maximum average packet rate measured in packets per time interval
  • time - specifies the time interval in which the packet rate is measured
  • burst - number of packets which are not counted by packet rate
log-prefix (string; Default: ) Adds specified text at the beginning of every log message. Applicable if action=log
new-connection-mark (string; Default: )
new-dscp (integer: 0..63; Default: )
new-mss (integer; Default: )
new-packet-mark (string; Default: )
new-priority (integer; Default: )
new-routing-mark (string; Default: )
new-ttl (decrement | increment | set:integer; Default: )
nth (integer,integer; Default: ) Matches every nth packet.
out-bridge-port (name; Default: ) Actual interface the packet is leaving the router, if outgoing interface is bridge
out-interface (; Default: ) Interface the packet is leaving the router
p2p (all-p2p | bit-torrent | blubster | direct-connect | edonkey | fasttrack | gnutella | soulseek | warez | winmx; Default: ) Matches packets from various peer-to-peer (P2P) protocols. Does not work on encrypted p2p packets.
packet-mark (no-mark | string; Default: ) Matches packets marked via mangle facility with particular packet mark. If no-mark is set, rule will match any unmarked packet.
packet-size (integer[-integer]:0..65535; Default: ) Matches packets of specified size or size range in bytes.
per-connection-classifier (ValuesToHashBig Grinenominator/Remainder; Default: ) PCC matcher allows to divide traffic into equal streams with ability to keep packets with specific set of options in one particular stream.
port (integer[-integer]: 0..65535; Default: ) Matches if any (source or destination) port matches the specified list of ports or port ranges. Applicable only if protocol is TCP or UDP
protocol (name or protocol ID; Default: tcp) Matches particular IP protocol specified by protocol name or number
psd (integer,time,integer,integer; Default: ) Attempts to detect TCP and UDP scans. Parameters are in following format WeightThreshold, DelayThreshold, LopPortWeight, HighPortWeight
  • WeightThreshold - total weight of the latest TCP/UDP packets with different destination ports coming from the same host to be treated as port scan sequence
  • DelayThreshold - delay for the packets with different destination ports coming from the same host to be treated as possible port scan subsequence
  • LowPortWeight - weight of the packets with privileged (<=1024) destination port
  • HighPortWeight - weight of the packet with non-priviliged destination port
random (integer: 1..99; Default: ) Matches packets randomly with given probability.
routing-mark (string; Default: ) Matches packets marked by mangle facility with particular routing mark
src-address (Ip/Netmaks, Ip range; Default: ) Matches packets which source is equal to specified IP or falls into specified IP range.
src-address-list (name; Default: ) Matches source address of a packet against user-defined address list
src-address-type (unicast | local | broadcast | multicast; Default: )

Matches source address type:

  • unicast - IP address used for point to point transmission
  • local - if address is assigned to one of router's interfaces
  • broadcast - packet is sent to all devices in subnet
  • multicast - packet is forwarded to defined group of devices
src-port (integer[-integer]: 0..65535; Default: ) List of source ports and ranges of source ports. Applicable only if protocol is TCP or UDP.
src-mac-address (MAC address; Default: ) Matches source MAC address of the packet
tcp-flags (ack | cwr | ece | fin | psh | rst | syn | urg; Default: ) Matches specified TCP flags
  • ack - acknowledging data
  • cwr - congestion window reduced
  • ece - ECN-echo flag (explicit congestion notification)
  • fin - close connection
  • psh - push function
  • rst - drop connection
  • syn - new connection
  • urg - urgent data
tcp-mss (integer: 0..65535; Default: ) Matches TCP MSS value of an IP packet
time (time-time,sat | fri | thu | wed | tue | mon | sun; Default: ) Allows to create filter based on the packets' arrival time and date or, for locally generated packets, departure time and date
ttl (equal | greater-than | less-than | not-equal : integer(0..255); Default: ) Matches packets TTL value.

Stats

/ip firewall filter print stats mostra proprietà aggiuntive in sola lettura.

Property Description
bytes (integer) Total amount of bytes matched by the rule
packets (integer) Total amount of packets matched by the rule

Marking packets:
"Marcare" un pacchetto consuma molte risorse alla routerboard.

Supponiamo che:

1) si vuole contrassegnare tutti i pacchetti TCP (tranne quelli sulla porta 80 e "marcare"questi pacchetti nella prima lista dell'address list;
2)contrassegnare tutti i pacchetti UDP e assegnarli alla seconda lista dell'address list;

Codice:
/ip firewall mangle
  add chain=forward protocol=tcp port=!80 dst-address-list=first action=mark-packet new-packet-mark=first
  add chain=forward protocol=udp dst-address-list=second action=mark-packet new-packet-mark=second

Il setup è molto semplice e funziona tranquillamente nelle reti di piccole dimensioni, ovviamente maggiore è il numero di indirizzi ip e di pacchetti maggiore sarà il consumo delle risorse della cpu della routerboard e della memoria della stessa. Per ottimizzare il setup è necessario attivare anche il mark delle connessioni, come di seguito evidenziato:

Codice:
/ip firewall mangle
  add chain=forward protocol=tcp port=!80 dst-address-list=first connection-state=new action=mark-connection \
new-connection-mark=first
  add chain=forward connection-mark=first action=mark-packet new-packet-mark=first passthrough=no

  add chain=forward protocol=udp dst-address-list=second connection-state=new action=mark-connection \
new-connection-mark=second
  add chain=forward connection-mark=second action=mark-packet new-packet-mark=second passthrough=no
La prima regola "marca" la connessione, la seconda "marca" il pacchetto. In tutto questo è stato disabilitato il passtrhrough che riduce il consumo di risorse.
[/hide]
Cita messaggio

#2
Sto cercando di configurare la priorità di tutti i pacchetti di un determinato ip (quello di un ata voip).
Per marcare i pacchetti ho fatto così
/ip firewall mangle
add chain=forward src-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP\
passthrough=no comment="VoIP" disabled=no
add chain=forward dst-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP2\
passthrough=no comment="VoIP" disabled=no

Però poi non so come dare le priorità.
Ho provato a fare 3 simple queue, una per i pacchetti marcati in entrata, una per quelli in uscita e una per tutto il resto ovvero target 0.0.0.0/24 e dest 0.0.0.0/0. Ai primi due ho dato priority 1 e all'ultimo ho dato priority 8. Ma facendo la prova di scaricare un'iso debian su 2 pc tra cui uno impostato sull'ip del voip la banda viene smistata e non va tutta all'ip 192.168.0.250.
Ecco uno screen delle queue:
http://oi39.tinypic.com/2a6m8ad.jpg
Cita messaggio

#3
(25-09-2013, 15:02)mannana93 Ha scritto: Sto cercando di configurare la priorità di tutti i pacchetti di un determinato ip (quello di un ata voip).
Per marcare i pacchetti ho fatto così
/ip firewall mangle
add chain=forward src-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP\
passthrough=no comment="VoIP" disabled=no
add chain=forward dst-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP2\
passthrough=no comment="VoIP" disabled=no

Però poi non so come dare le priorità.
Ho provato a fare 3 simple queue, una per i pacchetti marcati in entrata, una per quelli in uscita e una per tutto il resto ovvero target 0.0.0.0/24 e dest 0.0.0.0/0. Ai primi due ho dato priority 1 e all'ultimo ho dato priority 8. Ma facendo la prova di scaricare un'iso debian su 2 pc tra cui uno impostato sull'ip del voip la banda viene smistata e non va tutta all'ip 192.168.0.250.
Ecco uno screen delle queue:
http://oi39.tinypic.com/2a6m8ad.jpg


il marklo devi fare sui servizi non sull'ip in questo caso
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#4
(25-09-2013, 16:17)trottolino Ha scritto:
(25-09-2013, 15:02)mannana93 Ha scritto: Sto cercando di configurare la priorità di tutti i pacchetti di un determinato ip (quello di un ata voip).
Per marcare i pacchetti ho fatto così
/ip firewall mangle
add chain=forward src-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP\
passthrough=no comment="VoIP" disabled=no
add chain=forward dst-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP2\
passthrough=no comment="VoIP" disabled=no

Però poi non so come dare le priorità.
Ho provato a fare 3 simple queue, una per i pacchetti marcati in entrata, una per quelli in uscita e una per tutto il resto ovvero target 0.0.0.0/24 e dest 0.0.0.0/0. Ai primi due ho dato priority 1 e all'ultimo ho dato priority 8. Ma facendo la prova di scaricare un'iso debian su 2 pc tra cui uno impostato sull'ip del voip la banda viene smistata e non va tutta all'ip 192.168.0.250.
Ecco uno screen delle queue:
http://oi39.tinypic.com/2a6m8ad.jpg


il marklo devi fare sui servizi non sull'ip in questo caso

Ma nel caso d'esempio che ho fatto sopra ovvero i due download su due pc differenti perchè non funziona la priorizzazione ?
Cita messaggio

#5
(25-09-2013, 16:21)mannana93 Ha scritto:
(25-09-2013, 16:17)trottolino Ha scritto:
(25-09-2013, 15:02)mannana93 Ha scritto: Sto cercando di configurare la priorità di tutti i pacchetti di un determinato ip (quello di un ata voip).
Per marcare i pacchetti ho fatto così
/ip firewall mangle
add chain=forward src-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP\
passthrough=no comment="VoIP" disabled=no
add chain=forward dst-address=192.168.0.250 action=mark-packet new-packet-mark=VoIP2\
passthrough=no comment="VoIP" disabled=no

Però poi non so come dare le priorità.
Ho provato a fare 3 simple queue, una per i pacchetti marcati in entrata, una per quelli in uscita e una per tutto il resto ovvero target 0.0.0.0/24 e dest 0.0.0.0/0. Ai primi due ho dato priority 1 e all'ultimo ho dato priority 8. Ma facendo la prova di scaricare un'iso debian su 2 pc tra cui uno impostato sull'ip del voip la banda viene smistata e non va tutta all'ip 192.168.0.250.
Ecco uno screen delle queue:
http://oi39.tinypic.com/2a6m8ad.jpg


il marklo devi fare sui servizi non sull'ip in questo caso

Ma nel caso d'esempio che ho fatto sopra ovvero i due download su due pc differenti perchè non funziona la priorizzazione ?



perchè lo devi fare sui servizi e quindi sugli ip Wink
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#6
Quindi basta solo aggiungere tcp in protocol nei mark?
Potresti dare anche un'occhiata alle queue nello screenshot? nNn sono sicuro di aver messo bene gli indirizzi.
Cita messaggio

#7
(25-09-2013, 16:25)mannana93 Ha scritto: Quindi basta solo aggiungere tcp in protocol nei mark?
Potresti dare anche un'occhiata alle queue nello screenshot? nNn sono sicuro di aver messo bene gli indirizzi.

nello screen vedo tutto unlimited Sad quindi non penso che militi qualcosa, gli ip in quel modo sono tutti non stai dando alcuna priorità
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#8
Ma io non voglio limitare la banda in modo assoluto, voglio solo che se ad esempio il pc1 (con priority 8) scarica al 100% di banda e il pc2 (con priority 1) inizia un downlad quest'ultimo deve poter sottrarre tutta la banda al primo.
Cita messaggio

#9
(25-09-2013, 16:33)mannana93 Ha scritto: Ma io non voglio limitare la banda in modo assoluto, voglio solo che se ad esempio il pc1 (con priority 8) scarica al 100% di banda e il pc2 (con priority 1) inizia un downlad quest'ultimo deve poter sottrarre tutta la banda al primo.

appunto ma se non metti gli ip come fai?
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#10
Pensavo bastasse mettere i packet marks che hanno già l'ip.
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  [Mikrotik] Basic Firewall hamtarociaoo 21 8'135 16-08-2016, 15:47
Ultimo messaggio: tecnofan
Bug un altro esempio di configurazione del firewall hamtarociaoo 23 4'674 06-02-2015, 08:15
Ultimo messaggio: kikko
  Esempio sulla configurazione del firewall di RouterOS kikko 23 7'695 22-02-2014, 16:57
Ultimo messaggio: kikko
  [Mikrotik] Firewall: Address List hamtarociaoo 0 1'966 12-09-2013, 18:44
Ultimo messaggio: hamtarociaoo
  [Mikrotik] Firewall: Layer 7 hamtarociaoo 0 1'913 12-09-2013, 18:43
Ultimo messaggio: hamtarociaoo
  [Mikrotik] Firewall: Connection tracking hamtarociaoo 0 3'726 12-09-2013, 18:42
Ultimo messaggio: hamtarociaoo
Information [Mikrotik] RouterOS: il firewall hamtarociaoo 0 4'136 12-09-2013, 18:34
Ultimo messaggio: hamtarociaoo

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.