Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Improved auto upgrade script v3.X

#1
One little script to upgrade RrouterBoards automatically.
  • ) fetch file from main router containing latest ROS version number;
  • ) get currently running version number;
  • ) extract minor and major version numbers and compare them;
  • ) if version fetched from main router is newer then download combined package directly from mikrotik.com
  • ) reboot.
At first you should create file containing newest version number on main router.

Codice:
/file print file="latestVer";
/file set latestVer.txt content="3.13";
Now we are ready to run scripts on other routers:
Codice:
#########################################################################

Codice:
# download and upgrade

Codice:
#########################################################################


Codice:
# newest version

Codice:
:local lMajor;

Codice:
:local lMinor;


Codice:
# current version

Codice:
:local vMajor;

Codice:
:local vMinor;



Codice:
# auto detect platform

Codice:
:local platform [/system resource get architecture-name];


Codice:
:local myVer [/system resource get version];


Codice:
# fetch latest version

Codice:
/tool fetch address="172.16.0.1" path="currentVer.txt" user="admin" password="" mode=ftp;

Codice:
:local lVer [/file get currentVer.txt content];


Codice:
:for i from=0 to=([:len $myVer] - 1) do={  

Codice:
    :if ( [:pick $myVer $i] = ".") do={

Codice:
        :set vMajor [:tonum [:pick $myVer 0 $i]];

Codice:
        :set vMinor [:tonum [:pick $myVer ($i + 1) [:len $myVer]]] ;

Codice:
    }

Codice:
}


Codice:
:for i from=0 to=([:len $lVer] - 1) do={  

Codice:
    :if ( [:pick $lVer $i] = ".") do={

Codice:
        :set lMajor [:tonum [:pick $lVer 0 $i]];

Codice:
        :set lMinor [:tonum [:pick $lVer ($i + 1) [:len $lVer]]] ;

Codice:
    }

Codice:
}


Codice:
:if ($vMajor < 3) do={

Codice:
    :log warning "oOops: should never happen ( /tool fetch supported only on 3.x )";

Codice:
} else={

Codice:
    :if (($vMajor = $lMajor) && ($vMinor < $lMinor)) do={

Codice:
        :local pckgName ("routeros-" . $platform . "-" . $lMajor . "." . $lMinor . ".npk");

Codice:
        /tool fetch address="www.mikrotik.com" host="www.mikrotik.com" mode=http path="download/$pckgName";

Codice:
        /system reboot;

Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Exclamation Script: Notifica sovraccarico CPU hamtarociaoo 1 912 10-09-2016, 01:18
Ultimo messaggio: hunte88
Information [Mikrotik] Semi-Automating CPE ROS/Firmware/script updates and setting changes berryberry 0 729 17-06-2015, 11:54
Ultimo messaggio: berryberry
Information [Mikrotik] SXT 5HnD Alignment Script berryberry 0 955 17-06-2015, 11:47
Ultimo messaggio: berryberry
Information [Mikrotik] Yet Another Alignment Script With LEDs And Sound berryberry 0 1'002 17-06-2015, 11:07
Ultimo messaggio: berryberry
Information [Mikrotik] Automated Upgrade/Downgrade script V3.9+ berryberry 0 581 17-06-2015, 10:51
Ultimo messaggio: berryberry
Information [Mikrotik] Auto upgrade script V3.x berryberry 0 370 17-06-2015, 10:34
Ultimo messaggio: berryberry
Information [Mikrotik] Monitor logs, send email alert / run script berryberry 0 729 16-06-2015, 10:55
Ultimo messaggio: berryberry
Information [Mikrotik] Improved Netwatch II berryberry 0 307 16-06-2015, 09:54
Ultimo messaggio: berryberry
Information [Mikrotik ] Improved Netwatch berryberry 0 381 16-06-2015, 09:52
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience /Monitoring -ECMP Failover Script berryberry 0 540 16-06-2015, 09:45
Ultimo messaggio: berryberry

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.