Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Managing Power Distribution Unit via SMS

#1
Information 
Below a script to manage Aviosys 9258S, 9258HP, 9258DS, ... PDU via /tool sms
Warning : needs Routeros >= 6.2, see comments in the script.
Original page (in French):[/url]

Citazione:[url=http://blog.lekermeur.net/?p=2531][Immagine: Titre_LndkSmsPower.png]
Codice:
/system script run LndkSmsPower

Codice:
:global DV "pwr004"; /system script run LndkSmsPower


Switching outlet 2 of default device :
Codice:
global PR 2; /system script run LndkSmsPower


Cycling outlet 1 of default device :
Codice:
:global PR 1; :global OP "RE"; /system script run LndkSmsPower

Sending SMS

SMS to send to request state of pwr099 device, and then to switch outlet 3 of default device pwr015 :

Codice:
:cmd password script LndkSmsPower DV=pwr099


Codice:
:cmd password script LndkSmsPower PR=3


[Immagine: Screenshot_20150215.png]

Cycling outlet 3 of default device :
Codice:
:cmd password script LndkSmsPower OP=re PR=3


The LndkSmsPower script

Codice:
#######################################################################################

Codice:
# Script RouterOS LndkSmsPower                                                        #

Codice:
# Managing outlets of  Aviosys PDU 9258S, 9258HP and 9258DS via SMS                   #

Codice:
# Send state of outlets of the device, switch or reinit outlet                        #

Codice:
# Web page : http://blog.lekermeur.net/?p=2531                                        #

Codice:
# Marc Dilasser, Le Net du Kermeur, Fevrier 2015                                      #

Codice:
#######################################################################################


Codice:
:global DV

Codice:
:global PR

Codice:
:global OP

Codice:
:local  ADRIP     ""

Codice:
:local  HPORT

Codice:
:local  NETWORK   "MyNet"

Codice:
:local  DEVNAME   ""

Codice:
:local  MODEL     ""

Codice:
:local  PRISE     -1

Codice:
:local  NBJOB

Codice:
:local  NBSMS

Codice:
:local  VER

Codice:
:local  NBOPER

Codice:
:local  URL

Codice:
:local  ERR

Codice:
:local  OUTFILE   "LndkPowerState"

Codice:
:local  IDF

Codice:
:local  CONTENT

Codice:
:local  MSG

Codice:
:local  HHMMSS

Codice:
:local  IJ

Codice:
:local  IK

Codice:
:local  IL

Codice:
:local  ISTAT

Codice:
:local  IOSTATE

Codice:
:local  ITEM

Codice:
:local  PORT

Codice:
:local  NUMTEL

Codice:
:local  DEBUG  0

Codice:
:local  ADMIN

Codice:
:local  PASSWORD

Codice:
:local  OPER

Codice:
:local  AROPERS

Codice:
:local  ONOFF   [:toarray ("OFF,ON ")]

Codice:
:local  HEXA    [:toarray ("0,1,2,3,4,5,6,7,8,9,a,b,c,d,e,f")]

Codice:
:local  LANG

Codice:
:local  ARLANGS [:toarray ("en,fr")]

Codice:
:local  AAR  {

Codice:
             "address"={ en="address";                fr="adresse"   };

Codice:
             "outlet"={  en="outlet";                 fr="prise"     };

Codice:
             "device"={  en="device";                 fr="equipement"};

Codice:
             "model"={   en="model";                  fr="modele"    };

Codice:
             "state"={   en=" state of ";             fr=" etat de " };

Codice:
             "at"={      en=" at ";                   fr=" a "       };

Codice:
             "err200"={  en="sending sms error";      fr="erreur envoi SMS"     };

Codice:
             "err220"={  en="http error";             fr="erreur acces http"    };

Codice:
             "err230"={  en="Url non defined";        fr="Url non definie"      };

Codice:
             "err240"={  en="script already running"; fr="script deja en cours" };

Codice:
            }


Codice:
:global ChangeToMajOrMinCase do={

Codice:
                    :local S1

Codice:
                    :local S2 ""

Codice:
                    :local CH ""

Codice:
                    :local I1

Codice:
                    :local I2

Codice:
                    :local I3

Codice:
                    :local MINMAJ {

Codice:
                       "min"="abcdefghijklmnopqrstuvwxyz";

Codice:
                       "maj"="ABCDEFGHIJKLMNOPQRSTUVWXYZ";

Codice:
                    }

Codice:
                    :local SOURCE "min"

Codice:
                    :local TARGET "maj"

Codice:
                    :set S1 $1

Codice:
                    :set I2 [:len $S1]

Codice:
                    :if ($2 = 0) do={

Codice:
                        :set SOURCE "maj"; set TARGET "min";

Codice:
                    }

Codice:
                    :if ($I2 > 0) do={

Codice:
                       for I1 from=0 to=($I2 - 1)  do={

Codice:
                          :set CH [:pick $S1 $I1 ($I1 + 1)]

Codice:
                          :set I3 [:find ($MINMAJ->$SOURCE) $CH]

Codice:
                          :if ($I3 >= 0) do={

Codice:
                             :set CH [:pick ($MINMAJ->$TARGET) $I3 ($I3 + 1)]  

Codice:
                          }    

Codice:
                          :set S2 ($S2 . $CH)

Codice:
                       }

Codice:
                    }

Codice:
                    :return $S2

Codice:
                 }

Codice:
:local ToUpper    do={

Codice:
                    :global ChangeToMajOrMinCase

Codice:
                    :return [$ChangeToMajOrMinCase $1]

Codice:
                 }

Codice:
:local ToLower    do={

Codice:
                    :global ChangeToMajOrMinCase

Codice:
                    :return [$ChangeToMajOrMinCase $1 0]

Codice:
                 }

Codice:
# if ($VER >= 6.2)

Codice:
:local  DoHttp    do={

Codice:
                    :local LERR 0

Codice:
                    :do {

Codice:
                       /tool fetch url="$1" dst-path="$2"

Codice:
                    } on-error={

Codice:
                       :set LERR 1

Codice:
                    }

Codice:
                    :return $LERR

Codice:
                 }

Codice:
:local  DoSendSms do={

Codice:
                    :local LERR 0

Codice:
                    :local MESS

Codice:
                    :set MESS [:pick $3 0 158]

Codice:
                    :do {

Codice:
                       /tool sms send "$1" "$2" message="$MESS"

Codice:
                    } on-error={

Codice:
                       :set LERR 1

Codice:
                    }

Codice:
                    :return $LERR

Codice:
                 }

Codice:
#endif

Codice:
#######################################################################################

Codice:
# Valeurs a configurer suivant exploitation :                                         #

Codice:
#    - user et mot de passe Aviosys                                                   #

Codice:
#    - adresse ip                                                                     #

Codice:
#    - nom de device                                                                  #

Codice:
#    - modele                                                                         #

Codice:
#    - numero telephone destinataire du SMS, par defaut allowed-number de /tool sms   #

Codice:
#    - le device par defaut                                                           #

Codice:
# La variable DV du SMS, si presente, donne le device                                 #

Codice:
# La variable PR du SMS, si presente, donne la prise a basculer                       #

Codice:
# La variable OP du SMS, si presente, donne le type d'operation                       #

Codice:
#######################################################################################

Codice:
:if ([:len $DV] = 0) do={:set DV "pwr001"; }


Codice:
:set  ADMIN     "admin"

Codice:
:set  PASSWORD  "password"


Codice:
# Default lang is en

Codice:
# :set LANG "fr"


Codice:
:if ($DV = "pwr001") do={

Codice:
  :set ADRIP     "10.6.7.8"

Codice:
  :set DEVNAME   "pwr001"

Codice:
  :set MODEL     "9258S"

Codice:
}


Codice:
:if ($DV = "pwr009") do={

Codice:
  :set ADRIP     "10.6.2.9"

Codice:
  :set DEVNAME   "pwr009"

Codice:
  :set MODEL     "9258DSv1"

Codice:
  :set PASSWORD  "motdepasse"

Codice:
}


Codice:
:if ($DV = "pwr028") do={

Codice:
  :set ADRIP     "192.168.1.100"

Codice:
  :set DEVNAME   "pwr028"

Codice:
  :set MODEL     "9258DSv4"

Codice:
  :set DEBUG     1

Codice:
}


Codice:
:if ($DV = "pwr029") do={

Codice:
  :set ADRIP     "192.168.1.100"

Codice:
  :set HPORT     "8084"

Codice:
  :set DEVNAME   "pwr029"

Codice:
  :set MODEL     "9258HP"

Codice:
  :set PASSWORD  "motdepasse"

Codice:
  :set DEBUG     1

Codice:
}

Codice:
#######################################################################################

Codice:
# END OF CONFIG                                                                       #

Codice:
#######################################################################################


Codice:
#######################################################################################

Codice:
# CGI commands examples on different Aviosys models and responses                     #

Codice:
# 9258S    :                                                                          #

Codice:
#  > /tool fetch url="http://admin:password@192.168.1.100/Set.cmd\?CMD=GetPower"      #

Codice:
#  < <html>p61=0,p62=1,p63=0,p64=0</html>                                             #

Codice:
# 9258DSv1 : (firmware version 1.x)                                                   #

Codice:
#  > wget -qO- http://192.168.1.100/Set.cmd?user=admin+pass=password+CMD=GetSysIO     #

Codice:
#  <  IOVALUE:fb                                                                      #

Codice:
# 9258DSv4 : (firmware version 4.x)                                                   #

Codice:
#  > wget -qO- http://192.168.8.100/set.cmd?user=admin+pass=password+cmd=GetPower     #

Codice:
#  <  P61=0,P62=1,P63=1,P64=0,P65=1,P66=1,P67=1,P68=1                                 #

Codice:
# 9258HP   :                                                                          #

Codice:
#  > wget -qO- http://admin:password@192.168.1.100/SetPower.cgi?p4=1                  #

Codice:
#  < <TITLE>Set Power Control</TITLE><BODY>Power Control = P4:1,P3:0,P2:1,P1:1;<p>... #

Codice:
#######################################################################################

Codice:
:set NBJOB [/system script job print count-only where script=LndkSmsPower]

Codice:
if ($NBJOB > 1) do={

Codice:
  :log error ($AAR->"err240"->$LANG)

Codice:
  return 240

Codice:
}


Codice:
#######################################################################################

Codice:
# List of operations                                                                  #

Codice:
# Default operation is ST, only send STATE                                            #

Codice:
# If PR (outlet) is set, defaut OP is SW, to switch this outlet                       #

Codice:
# If OP is RE (reinit) and PR is set, operations are STATE,SWITCH,DELAY,SWITCH,STATE  #

Codice:
# If OP is LI (list names of outlets), operation is LIST (not implemented yet)        #

Codice:
#######################################################################################


Codice:
:if (([:len [:find $ARLANGS $LANG]]) = 0) do={ :set LANG "en"; }


Codice:
:if ([:len $OP] = 0) do={

Codice:
  :set OP "ST";

Codice:
  :if ([:len $PR] = 1) do={ :set OP "SW"; }

Codice:
} else={

Codice:
  :set OP [$ToUpper $OP]

Codice:
}


Codice:
:set AROPERS [:toarray ("STATE")]

Codice:
:if ($OP = "SW") do={

Codice:
  :if ([:len $PR] = 1) do={

Codice:
     :set AROPERS [:toarray ("STATE,SWITCH,STATE")]

Codice:
  }

Codice:
}

Codice:
:if ($OP = "RE") do={

Codice:
  :if ([:len $PR] = 1) do={

Codice:
     :set AROPERS [:toarray ("STATE,SWITCH,STATE,DELAY20,SWITCH,STATE")]

Codice:
  }

Codice:
}

Codice:
:if ($OP = "LI") do={

Codice:
  :set AROPERS [:toarray ("LIST")]

Codice:
}

Codice:
:if ([:len $PR] > 0) do={

Codice:
  :set PRISE ([:tonum $PR] - 1);

Codice:
}

Codice:
:if ([:len $OP] = 0) do={ :set OP ""; }

Codice:
:set VER [/system resource get version]

Codice:
:set MSG (($AAR->"device"->$LANG) . " " . $DEVNAME . ", ")

Codice:
:set MSG ($MSG . ($AAR->"model"->$LANG) . " " . $MODEL . ", ")

Codice:
:set MSG ($MSG . ($AAR->"address"->$LANG) . " " . $ADRIP)

Codice:
:log info $MSG


Codice:
#######################################################################################

Codice:
# Do while some operation to do                                                       #

Codice:
#######################################################################################

Codice:
foreach OPER in ($AROPERS) do={

Codice:
  :if ($OPER = "STATE") do={

Codice:
     :set URL ""      

Codice:
     :if ($MODEL = "9258S") do={

Codice:
        :set URL ("http://" . $ADMIN . ":" . $PASSWORD . "@" . $ADRIP )

Codice:
        :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
        :set URL ($URL . "/Set.cmd\?CMD=GetPower")

Codice:
     }

Codice:
     :if ($MODEL = "9258DSv1") do={

Codice:
        :set URL ("http://" . $ADRIP);

Codice:
        :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
        :set URL ($URL . "/Set.cmd\?user=" . $ADMIN )

Codice:
        :set URL ($URL . "+pass=" . $PASSWORD . "+CMD=GetSysIO")

Codice:
     }

Codice:
     :if ($MODEL = "9258DSv4") do={

Codice:
        :set URL ("http://" . $ADRIP)

Codice:
        :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
        :set URL ($URL . "/set.cmd\?user=" . $ADMIN )

Codice:
        :set URL ($URL . "+pass=" . $PASSWORD . "+cmd=GetPower")

Codice:
     }

Codice:
     :if ($MODEL = "9258HP") do={

Codice:
        :set URL ("http://" . $ADRIP)

Codice:
        :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
        :set URL ($URL . "/GetPower.cgi")

Codice:
     }

Codice:
     :if ([:len $URL] = 0) do={

Codice:
        :return 250

Codice:
     } else={  

Codice:
        :if ($DEBUG > 0) do={ :put "Url : $URL";  }

Codice:
     }

Codice:
     :set ERR 0

Codice:
# if ($VER >= 6.2)

Codice:
     :set ERR [$DoHttp $URL $OUTFILE]

Codice:
# else

Codice:
# :set ERR 0

Codice:
# /tool fetch url=$URL dst-path=$OUTFILE

Codice:
# endif

Codice:
     :if ($ERR < 1) do={

Codice:
        :set IDF [/file find where name=$OUTFILE]

Codice:
        :set CONTENT [ /file get $IDF contents]

Codice:
        :if ($DEBUG > 0) do={ :put $CONTENT; }

Codice:
        :set HHMMSS [/system clock get time]

Codice:
        :set MSG ($NETWORK . " :" . ($AAR->"state"->$LANG))

Codice:
        :set MSG ($MSG . $DEVNAME . ($AAR->"at"->$LANG) . $HHMMSS . "\n")


Codice:
        :if ($MODEL = "9258DSv1") do={

Codice:
           :set ISTAT [:tonum ("0x" . [:pick $CONTENT 9 11])]

Codice:
           :set IOSTATE $ISTAT

Codice:
           :set IJ 0

Codice:
           while ($IJ < 8) do={

Codice:
              :set IK ($ISTAT % 2)

Codice:
              :set MSG ($MSG . ($AAR->"outlet"->$LANG) . " " . [:tostr ($IJ + 1)] )

Codice:
              :set MSG ($MSG . ": " . [:pick $ONOFF $IK] . " ")

Codice:
              :if (($IJ % 2) = 1) do={ :set MSG ($MSG . "\n"); }

Codice:
              :set ISTAT ($ISTAT / 2)

Codice:
              :set IJ ($IJ + 1)

Codice:
           }

Codice:
        }

Codice:
        :if (($MODEL = "9258S") || ($MODEL = "9258DSv4")) do={

Codice:
           :if ($MODEL = "9258S") do={

Codice:
               :set IJ 10;

Codice:
               :set IK 4;

Codice:
            } else={

Codice:
               :set IJ 5;

Codice:
               :set IK 8;

Codice:
            }

Codice:
           :if (([:pick $CONTENT 0 6] = "<html>") || ([:pick $CONTENT 0 5] = " P61=")) do={

Codice:
              :for IL from=1 to=$IK do={

Codice:
                 :set MSG ($MSG . "   " . ($AAR->"outlet"->$LANG) . " " . ([:tostr $IL]) . ": ")

Codice:
                 :set MSG ($MSG . ([:pick $ONOFF [:pick $CONTENT ($IJ + (($IL - 1) * 6)) ]]))

Codice:
                 :if ((($IL % 2) = 0) && ($IL < $IK)) do={

Codice:
                    :set MSG ($MSG . "\n")

Codice:
                 }

Codice:
              }

Codice:
              :if ( $PRISE > -1 ) do={

Codice:
                 :set IOSTATE [:pick $CONTENT ($IJ + (6 * $PRISE))]

Codice:
                 :log info (($AAR->"outlet"->$LANG) . " " . ($PRISE + 1) . ", iostate : $IOSTATE")

Codice:
              }

Codice:
           }

Codice:
        }

Codice:
        :if ($MODEL = "9258HP") do={

Codice:
           :set IJ [:find $CONTENT "Control = P4"]

Codice:
           :if ([:len $IJ] > 0) do={

Codice:
              :set IJ ($IJ + 13)

Codice:
              :set MSG ($MSG . "   " . ($AAR->"outlet"->$LANG) . " 1: ")

Codice:
              :set MSG ($MSG . ([:pick $ONOFF [:pick $CONTENT ($IJ + 15) ]]))

Codice:
              :set MSG ($MSG . ", " . ($AAR->"outlet"->$LANG) . " 2: ")

Codice:
              :set MSG ($MSG . ([:pick $ONOFF [:pick $CONTENT ($IJ + 10) ]]) . "\n")

Codice:
              :set MSG ($MSG . "   " . ($AAR->"outlet"->$LANG) . " 3: ")

Codice:
              :set MSG ($MSG . ([:pick $ONOFF [:pick $CONTENT ($IJ + 5) ]]))

Codice:
              :set MSG ($MSG . ", " . ($AAR->"outlet"->$LANG) . " 4: ")

Codice:
              :set MSG ($MSG . ([:pick $ONOFF [:pick $CONTENT $IJ ]]))

Codice:
              :if ( $PRISE > -1 ) do={

Codice:
                 :set IOSTATE [:pick $CONTENT ($IJ + (5 * $PRISE))]

Codice:
                 :log info (($AAR->"outlet"->$LANG) . " " . ($PRISE + 1) . ", iostate : $IOSTATE")

Codice:
              }

Codice:
           }

Codice:
        }

Codice:
        :if ([:len $MSG] > 60) do={

Codice:
           :if ($DEBUG = 0) do={

Codice:
              :set PORT [/tool sms get port]

Codice:
              :if ([:len $NUMTEL] = 0) do={

Codice:
                 :set NUMTEL [/tool sms get allowed-number]

Codice:
              }

Codice:
# if ($VER >= 6.2)

Codice:
              :set ERR [$DoSendSms $PORT $NUMTEL $MSG]

Codice:
              :if ($ERR > 0) do={

Codice:
                 :log error ($AAR->"err200"->$LANG)

Codice:
                 return 200

Codice:
              }

Codice:
# else

Codice:
# /tool sms send ...

Codice:
# endif

Codice:
           } else={

Codice:
              :put ($MSG)

Codice:
              :log info ($MSG)

Codice:
           }

Codice:
        }

Codice:
        /file remove $IDF

Codice:
     } else={

Codice:
        :log error ($AAR->"err220"->$LANG)

Codice:
        return 220;

Codice:
     }

Codice:
  }


Codice:
  :if ($OPER = "SWITCH") do={

Codice:
     :if (([:len $PRISE] = 1) && ([:len $IOSTATE] > 0)) do={

Codice:
        :set URL ""      

Codice:
        :if ($MODEL = "9258S") do={

Codice:
           :set URL ("http://" . $ADMIN . ":" . $PASSWORD . "@")

Codice:
           :set URL ($URL . $ADRIP)

Codice:
           :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
           :set URL ($URL . "/Set.cmd\?CMD=SetPower")

Codice:
           :set URL ($URL . "+P6" . [:tostr ($PRISE + 1)] . "=")

Codice:
           :set URL ($URL . [:tostr (($IOSTATE + 1) % 2)])

Codice:
        }

Codice:
        :if ($MODEL = "9258DSv4") do={

Codice:
           :set URL ("http://" . $ADMIN . ":" . $PASSWORD . "@")

Codice:
           :set URL ($URL . $ADRIP)

Codice:
           :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
           :set URL ($URL . "/set.cmd\?cmd=setpower")

Codice:
           :set URL ($URL . "+p6" . [:tostr ($PRISE + 1)] . "=")

Codice:
           :set URL ($URL . [:tostr (($IOSTATE + 1) % 2)])

Codice:
        }

Codice:
        :if ($MODEL = "9258DSv1") do={

Codice:
           :set URL ("http://" . $ADRIP)

Codice:
           :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
           :set URL ($URL . "/Set.cmd\?user=" . $ADMIN )

Codice:
           :set URL ($URL . "+pass=" . $PASSWORD . "+CMD=SetSysIO+IO=")

Codice:
           :set IJ 8

Codice:
           :set IK 0

Codice:
           while ($IJ > 0) do={

Codice:
              :set IK ($IK * 2)

Codice:
              :if ($IJ = ($PRISE + 1)) do={ :set IK ($IK + 1); }

Codice:
              :set IJ ($IJ - 1)

Codice:
           }

Codice:
           :set IJ ( $IOSTATE ^ $IK)

Codice:
           :set URL ($URL . [:pick $HEXA ($IJ / 16)])

Codice:
           :set URL ($URL . [:pick $HEXA ($IJ % 16)])

Codice:
           :set URL ($URL . "+Delay=1")

Codice:
        }

Codice:
        :if ($MODEL = "9258HP") do={

Codice:
           :set URL ("http://" . $ADMIN . ":" . $PASSWORD . "@")

Codice:
           :set URL ($URL . $ADRIP)

Codice:
           :if ([:len $HPORT] > 0) do={ :set URL ($URL . ":" . $HPORT); }

Codice:
           :set URL ($URL . "/SetPower.cgi\?p")

Codice:
           :set URL ($URL . [:tostr ($PRISE + 1)] . "=")

Codice:
           :set URL ($URL . [:tostr (($IOSTATE + 1) % 2)])

Codice:
        }

Codice:
        :if ([:len $URL] = 0) do={

Codice:
           :log error ($AAR->"err230"->$LANG)

Codice:
           :return 230

Codice:
        }

Codice:
        :if ($DEBUG > 0) do={

Codice:
           :put "Url : $URL"

Codice:
           :log info "Url : $URL"

Codice:
        } else={

Codice:
           :log info "Url : $URL"

Codice:
# if ($VER >= 6.2)

Codice:
           :set ERR [$DoHttp $URL $OUTFILE]

Codice:
# else

Codice:
# :set ERR 0

Codice:
# /tool fetch url=$URL dst-path=$OUTFILE

Codice:
# endif

Codice:
           :if ($ERR < 1) do={

Codice:
              :set IDF [/file find where name=$OUTFILE]

Codice:
              /file remove $IDF

Codice:
           }

Codice:
        }

Codice:
     } else={

Codice:
        :log error ($AAR->"err220"->$LANG)

Codice:
        :return 220

Codice:
     }

Codice:
  }


Codice:
  :if ($OPER = "DELAY20") do={

Codice:
     :delay 20

Codice:
  }


Codice:
  :if ($OPER = "LIST") do={

Codice:
     :delay 1

Codice:
  }

Codice:
}


Codice:
#######################################################################################

Codice:
# Some cleanings                                                                      #

Codice:
#######################################################################################

Codice:
:foreach ITEM in ("DV", "OP", "PR") do={

Codice:
  /system script environment remove [find where name=$ITEM]

Codice:
}


Codice:
:set NBSMS [/tool sms inbox print count-only]

Codice:
:if ($NBSMS >= 30) do={

Codice:
  /tool sms inbox remove 0,1,2,3,4,5,6,7,8,9

Codice:
}

Codice:
###########   End of LndkSmsPower   ###########   That's All, Folks   ###########

Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.