Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] PPP Keepalive ping

#1
Information 
The goal
I recently ran into an issue where PPTP connections would drop packets after idle time of 00:01:00 (1 min). I wrote this little script to run within this time, which resets idle time to 00:00:00, effectively solving this issue.

The script
Codice:
# Script: PPTP-KeepAlive
:local addr
/ppp active {
  :foreach i in=[find] do={
     :if ([get $i service] = "pptp") do={
        :set addr [get $i address]
        /ping ($addr) count=1

The schedule
Codice:
/system scheduler
add comment="" disabled=no interval=45s name=PPTP-KeepAlive on-event=\
   PPTP-KeepAlive policy=read,test start-time=startup



Cita messaggio

#2
Sorry i am newbie and i have to ask you a similar script. Sometimes in my mikrotik i lose all ppp connection, in this case i have to simply reboot the system to solve the problem. How can i write a script to automatically reboot the system in presence of zero ppp conecctions ?
THANK YOU
Cita messaggio

#3
Fammi capire bene quale è il tuo problema grazie

Inviato dal mio SM-T335 utilizzando Tapatalk
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#4
Perché non lo inserisci nella sezione script?
Grazie

Inviato dal mio SM-T335 utilizzando Tapatalk
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.