Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Proteggere la rete lan

#1
Per proteggere la rete lan è necessario analizzare tutto il traffico che passa attraverso il router in modo tale da poter bloccare il traffico indesiderato. Per il traffico ICMP, TCP ed UDP creeremo delle chain eliminando tutti i pacchetti indesiderati. Il primo passo è quello di copiare e incollare i seguenti comandi nella console del terminale RouterOS:
[hide]
Codice:
/ip firewall filter
add chain=forward connection-state=established comment="allow established connections"  
add chain=forward connection-state=related comment="allow related connections"
add chain=forward connection-state=invalid action=drop comment="drop invalid connections"

[Immagine: e0g2.jpg]

Lo step successivo è quello di proteggere la rete lan dai più noti virus, quindi copiare ed incollare il seguente codice:

Codice:
add chain=virus protocol=tcp dst-port=135-139 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=udp dst-port=135-139 action=drop comment="Drop Messenger Worm"    
add chain=virus protocol=tcp dst-port=445 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=udp dst-port=445 action=drop comment="Drop Blaster Worm"
add chain=virus protocol=tcp dst-port=593 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1080 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=1214 action=drop comment="________"
add chain=virus protocol=tcp dst-port=1363 action=drop comment="ndm requester"
add chain=virus protocol=tcp dst-port=1364 action=drop comment="ndm server"
add chain=virus protocol=tcp dst-port=1368 action=drop comment="screen cast"
add chain=virus protocol=tcp dst-port=1373 action=drop comment="hromgrafx"
add chain=virus protocol=tcp dst-port=1377 action=drop comment="cichlid"
add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Bagle Virus"
add chain=virus protocol=tcp dst-port=2283 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=2535 action=drop comment="Drop Beagle"
add chain=virus protocol=tcp dst-port=2745 action=drop comment="Drop Beagle.C-K"
add chain=virus protocol=tcp dst-port=3127-3128 action=drop comment="Drop MyDoom"
add chain=virus protocol=tcp dst-port=3410 action=drop comment="Drop Backdoor OptixPro"
add chain=virus protocol=tcp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=udp dst-port=4444 action=drop comment="Worm"
add chain=virus protocol=tcp dst-port=5554 action=drop comment="Drop Sasser"
add chain=virus protocol=tcp dst-port=8866 action=drop comment="Drop Beagle.B"
add chain=virus protocol=tcp dst-port=9898 action=drop comment="Drop Dabber.A-B"
add chain=virus protocol=tcp dst-port=10000 action=drop comment="Drop Dumaru.Y"
add chain=virus protocol=tcp dst-port=10080 action=drop comment="Drop MyDoom.B"
add chain=virus protocol=tcp dst-port=12345 action=drop comment="Drop NetBus"
add chain=virus protocol=tcp dst-port=17300 action=drop comment="Drop Kuang2"
add chain=virus protocol=tcp dst-port=27374 action=drop comment="Drop SubSeven"
add chain=virus protocol=tcp dst-port=65506 action=drop comment="Drop PhatBot, Agobot, Gaobot"
add chain=forward action=jump jump-target=virus comment="jump to the virus chain"

La chain assume il seguente aspetto:

[Immagine: 6lr3.jpg]

Se il pacchetto non corrisponde a nessuna delle regole lo stesso è restituito di nuovo alla chain forward.
In queswto caso abbiamo consentito tutto il traffico HTTP e SMTP ed alcuni pacchetti TCP e UDP e ICMP (Ping).
Le regole che seguono consentono tutto il traffico specificato:
Codice:
add chain=forward action=accept protocol=tcp dst-port=80 comment="Allow HTTP"
add chain=forward action=accept protocol=tcp dst-port=25 comment="Allow SMTP"
add chain=forward protocol=tcp comment="allow TCP"
add chain=forward protocol=icmp comment="allow ping"
add chain=forward protocol=udp comment="allow udp"
add chain=forward action=drop comment="drop everything else"
[/hide]
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#2
L ultima tegola va inserita?

Inviato dal mio GT-I9300 con Tapatalk 2
Cita messaggio

#3
L'ultima regola va assolutamente inserita, cerca di capirne il significato di quello che fai Wink

sent from my Nexsus 7 using Tapatalk
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#4
(15-12-2013, 19:35)trottolino Ha scritto: L'ultima regola va assolutamente inserita, cerca di capirne il significato di quello che fai Wink

sent from my Nexsus 7 using Tapatalk

Va a completare le altre regole che ho già incollato....
Se arriva un qualcosa che non viene gestito dalle regole precedenti, quest ultima fa si che ritorni verso il firewall.
Inviato dal mio GT-I9300 con Tapatalk 2
Cita messaggio

#5
(15-12-2013, 19:50)nicozan72 Ha scritto:
(15-12-2013, 19:35)trottolino Ha scritto: L'ultima regola va assolutamente inserita, cerca di capirne il significato di quello che fai Wink

sent from my Nexsus 7 using Tapatalk

Va a completare le altre regole che ho già incollato....
Se arriva un qualcosa che non viene gestito dalle regole precedenti, quest ultima fa si che ritorni verso il firewall.
Inviato dal mio GT-I9300 con Tapatalk 2

Io lo so che fa lo devi capire tu.
In ogni caso il firewall funziona al contrario, fa passare solo quello che autorizzi e non tutto e poi lo analizza.


sent from my Nexsus 7 using Tapatalk
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#6
Ma queste regole per la protezione dai virus non è che vanno a bloccare/diminuire il traffico in /out di periferiche della lan domestica?

Inviato dal mio GT-I9300 con Tapatalk 2
Cita messaggio

#7
io ho le ho attive da tempo e va tutto a meraviglia
Cita messaggio

#8
Ciao a tutti, vorrei capire queste regole in quanto mi sto affacciando ora al firewall di ROS Big Grin

Dunque la prima parte di regole analizza il traffico ICMP, TCP ed UDP bloccando il traffico indesiderato. Ma quest'ultimo come è definito ? Dalla seconda parte di regole e cioè passa tutto il traffico tranne "i virus" ? Inoltre mi pare di capire che se dopo queste analisi è tutto ok il traffico viene "passato" tramite la regola chain forward giusto?

In poche parole viene "accettato tutto" tranne i pacchetti-virus contenuti nella 2 regola giusto ?

Tutto il resto del traffico ICMP, TCP e UDP viene passato tramite l'ultima regola (la terza).

Quindi in poche parole si può riassumere cosi:

la prima regola inserisce un filtro su i protocolli specificati
la seconda regola esegue un controllo alla ricerca di quei pacchetti e se li identifica li blocca
la terza regola permette il passaggio del resto dei pacchetti 

Grazie a quest'ultima regola quindi per esempio se utilizzassi qualche programma che utilizza la porta TCP o UDP X non avrei problemi di blocchi indesiderati.

È corretto ? Big Grin
Cita messaggio

#9
prima di addentrarci nelle specifiche regole del firewall che hai segnalato ti consiglio di effettuare 3 ricerche sul forum su icmp tcp e udp così abbiamo le idee chiare.
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#10
Chiaramente le regole scritte sopra vanno inserite esattamente nell'ordine dato giusto? Perché vengono eseguite in ordine, giusto?
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  [Mikrotik] Proteggere la routerboard dal port scan hamtarociaoo 16 4'212 12-05-2016, 10:30
Ultimo messaggio: dancollins

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.