Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Proteggersi dagli attacchi DOS

#1
Gli attacchi DOS provocano un sovraccarico sul router portando la cpu fino al 100%, causando quindi blocchi.
[hide]
In generale non esiste una soluzione perfetta per la protezione contro gli attacchi DoS. Ogni servizio può sovraccaricare il router con troppe richieste. Esistono alcuni metodi per ridurre al minimo l'impatto di un attacco.
Di seguito le regole da aggiungere:

Codice:
/ip firewall filter add chain=input protocol=tcp connection-limit=LIMIT,32  \
action=add-src-to-address-list  address-list=blocked-addr address-list-timeout=1d

EDIT:

su RouterOS 6.X bisogna sostituire lo script con questo:

Codice:
/ip firewall filter add chain=input protocol=tcp connection-limit=LIMIT,32  \
action=add-src-to-address-list  address-list=blocked-addr address-list-timeout=1d

Codice:
/ip firewall filter add chain=input protocol=tcp src-address-list=blocked-addr \
connection-limit=3,32 action=tarpit

Codice:
/ip firewall filter add chain=forward protocol=tcp tcp-flags=syn connection-state=new \
action=jump jump-target=SYN-Protect comment="SYN Flood protect" disabled=yes
/ip firewall filter add chain=SYN-Protect protocol=tcp tcp-flags=syn limit=400,5 connection-state=new \
action=accept comment="" disabled=no
/ip firewall filter add chain=SYN-Protect protocol=tcp tcp-flags=syn connection-state=new \
action=drop comment="" disabled=no
Codice:
/ip firewall connection tracking set tcp-syncookie=yes
EDIT: Inutile nella 6.X
[/hide]
Cita messaggio

#2
(12-09-2013, 18:35)hamtarociaoo Ha scritto:
Gli attacchi DOS provocano un sovraccarico sul router portando la cpu fino al 100%, causando quindi blocchi.
[hide]
In generale non esiste una soluzione perfetta per la protezione contro gli attacchi DoS. Ogni servizio può sovraccaricare il router con troppe richieste. Esistono alcuni metodi per ridurre al minimo l'impatto di un attacco.
Di seguito le regole da aggiungere:

Codice:
/ip firewall filter add chain=input protocol=tcp connection-limit=LIMIT,32  \
action=add-src-to-address-list  address-list=blocked-addr address-list-timeout=1d

Codice:
/ip firewall filter add chain=input protocol=tcp src-address-list=blocked-addr \
connection-limit=3,32 action=tarpit

Codice:
/ip firewall filter add chain=forward protocol=tcp tcp-flags=syn connection-state=new \
action=jump jump-target=SYN-Protect comment="SYN Flood protect" disabled=yes
/ip firewall filter add chain=SYN-Protect protocol=tcp tcp-flags=syn limit=400,5 connection-state=new \
action=accept comment="" disabled=no
/ip firewall filter add chain=SYN-Protect protocol=tcp tcp-flags=syn connection-state=new \
action=drop comment="" disabled=no
Codice:
/ip firewall connection tracking set tcp-syncookie=yes
[/hide]

Quando inserisco la prima regola mi dice:

value of limit contains invalid trailing characters
Cita messaggio

#3
Come la inserisci ? Fai copia incolla? Se si sbagli qualcosa quindi ti conviene scriverle a mano, quindi copiarle !

sent from my Nexsus 7 using Tapatalk
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#4
O ancora meglio inseriscile manualmente da winbox
Cita messaggio

#5
(15-12-2013, 18:25)trottolino Ha scritto: Come la inserisci ? Fai copia incolla? Se si sbagli qualcosa quindi ti conviene scriverle a mano, quindi copiarle !

sent from my Nexsus 7 using Tapatalk

Faccio select all, tasto destro, copia, poi incollo su new terminal. Ci vengono dei puntini che non ci dovrebbero essere. Do invio e da errore scritto.

Inviato dal mio GT-I9300 con Tapatalk 2
Cita messaggio

#6
Scrivi tutto a mano, window fa questi scherzi

sent from my Nexsus 7 using Tapatalk
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#7
(15-12-2013, 18:58)trottolino Ha scritto: Scrivi tutto a mano, window fa questi scherzi

sent from my Nexsus 7 using Tapatalk

Ho scaricato PuTTY e via telnet mi sono collegato al terminale della RouterBoard senza espandere la finestra telnet . Ho copiato tutto il comando a mano e andava a capo da solo quando arrivavo al limite di tale finestra. Dando invio a fine comando mi dava ugualmente errore in qualche colonna!

Inviato dal mio GT-I9300 con Tapatalk 2
Cita messaggio

#8
versione di routeros?
Cita messaggio

#9
Al posto del primo script usa questo:

Codice:
/ip firewall filter add chain=input protocol=tcp connection-limit=LIMIT,32  \
action=add-src-to-address-list  address-list=blocked-addr address-list-timeout=1d
Cita messaggio

#10
(17-12-2013, 18:00)hamtarociaoo Ha scritto: versione di routeros?

Ultima uscita 6.7


(17-12-2013, 18:13)hamtarociaoo Ha scritto: Al posto del primo script usa questo:

Codice:
/ip firewall filter add chain=input protocol=tcp connection-limit=LIMIT,32  \
action=add-src-to-address-list  address-list=blocked-addr address-list-timeout=1d

Ok provo.

Inviato dal mio GT-I9300 con Tapatalk 2

Mi dice (putty):

value of limit contains invalid trailing characters !!!
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.