Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Reboot Boards due to low Memory with notification

#1
Information 
set this in scheduler to get lost memory back and to get a reboot when it needs to do this
Codice:
:global datum [/system clock get date];

Codice:
:global time [/system clock get time];

Codice:
/system resource

Codice:
:if ([get free-memory]< 25000) do=[

Codice:
/tool e-mail send server=*.*.*.* to="alert@yours.net" subject=[/system identity get name]


Codice:
from="alert@yours.net" body=(" on $datum at $time the memory on this repeater got to ", [/system resource


Codice:
get free-memory])

Codice:
/system reboot;

Codice:
]};


on the if statement you will need to set the 25000 depending on board type IE 532a = 25000 153 = 12000 and so on I put this in scheduler to run at 3am once a day

Using percentages
Codice:
global datum [/system clock get date];

Codice:
:global time [/system clock get time];

Codice:
:local percentfree ((100 * [/system resource get free-memory]) / [/system resource get total-memory])


Codice:
/system resource

Codice:
:if ($percentfree < 5) do={

Codice:
 /tool e-mail send server=*.*.*.* to="alert@yours.net" subject=[/system identity get name] from="alert@yours.net" body=(" on $datum at $time the memory on this repeater got to ", [/system resource get free-memory])

Codice:
 /system reboot;

Codice:
};

Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Information [Mikrotik] Send email about reboot berryberry 0 530 16-06-2015, 11:11
Ultimo messaggio: berryberry

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.