Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Remotely change password for managers

#1
Information 
Script to remotely change password for MikroTik managers.
  • fetch file from local web server;
  • get file content;
  • reset manager's password;
  • scheduled every 1h to recheck changes;
At first you should paste this in Terminal, it will create GROUP managers and USERNAME manager with start PASSWORD manager. After that it will create script "change-pass" with fetch function where you MUST change WEB-SERVER-IP to Your web servers IP and filename pass54321.txt to something random. At end it will add Scheduler to recheck content of file. Also if You want you can change policy of new group to add specified limitations.
group add, user add, script add, scheduler add

Codice:
/user group add name=managers policy=ftp,read,local,policy,reboot,ssh,winbox
/user add name=manager group=managers password=manager

/system script add name="change-pass" source={
/tool fetch address=WEB-SERVER-IP src-path=pass54321.txt ;
:global password [/file get pass54321.txt contents] ;
/user set manager password=$password ;
}

/system scheduler add interval=1h name="password" on-event=change-pass
file content

Content of pass54321.txt should look like this:

Codice:
SoMePasSWorD

Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  Guida: Cambio password da remoto hamtarociaoo 0 620 01-11-2013, 11:20
Ultimo messaggio: hamtarociaoo

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.