Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 1 voto(i) - 5 media
  • 1
  • 2
  • 3
  • 4
  • 5
Script: Notifica sovraccarico CPU

#1
Exclamation 
questo script consente di inviare una e-mail ad un indirizzo da noi specificato in caso di sovraccarico della CPU (il valore di avvertimento può essere regolato a piacimento):
[hide]
Codice:
/system script
add name=UtilizzoCPU policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source=":global datum [/system clock get date];\r\
    \n:global time [/system clock get time];\r\
    \n:local maxsamples 5\r\
    \n:global cpuarray\r\
    \n:set cpuarray ([/system resource get cpu-load] , [:pick \$cpuarray 0 (\$ma\
    xsamples - 1)])\r\
    \n:local arraytot 0\r\
    \n:foreach o in=\$cpuarray do={:set arraytot (\$arraytot + \$o)};\r\
    \n:local arraysize [:len \$cpuarray]\r\
    \n:local avgcpuload (\$arraytot / \$arraysize)\r\
    \n:log info (\"CPU Load Captures:\")\r\
    \n:log info \$cpuarray\r\
    \n:log info (\"Array Total: \$arraytot\")\r\
    \n:log info (\"Array size: \$arraysize of \$maxsamples\")\r\
    \n:global highavgcpuload\r\
    \n:if ([:len \$highavgcpuload] = 0 || \$highavgcpuload < \$avgcpuload) do={:\
    set highavgcpuload \$avgcpuload}\r\
    \n:log info (\"CPU Load - Avg: \$avgcpuload High: \$highavgcpuload\")\r\
    \n:if (\$avgcpuload >= 95) do={\r\
    \n/tool e-mail send to=\"xxx@gmail.com\" subject=[/system identity ge\
    t name] from=\"xxx@gmail.com\" body=([/system identity get name] ,\" \
    At \$time the CPU Load on this router was running at 95%\")\r\
    \n};"

potete modificare il valore "95" con uno a vostro piacimento

per tenere in esecuzione lo script facciamo:

Codice:
add interval=1m name=MonitorRisorse on-event="/system script run UtilizzoCPU" \
    policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-date=apr/22/2014 start-time=08:51:31

N.B: facciamo attenzione che in /tool e-mail tutto sia configurato correttamente, altrimenti le email non verranno inviate
[/hide]
Cita messaggio

#2
Ciao ragazzi,

lo script in questione non so perchè ma presenta degli \n e \r\ (forse è stato copiato da un editor di testo con qualche funzione particolare).

In ogni caso vi riposto qui lo script che ho testato e quindi funzionante, ma solo se inserito da interfaccia grafica:

Codice:
:global datum [/system clock get date];
:global time [/system clock get time];
:local maxsamples 5
:global cpuarray
:set cpuarray ([/system resource get cpu-load] , [:pick $cpuarray 0 ($maxsamples - 1)])
:local arraytot 0
:foreach o in=$cpuarray do={:set arraytot ($arraytot + $o)};
:local arraysize [:len $cpuarray]
:local avgcpuload ($arraytot / $arraysize)
:log info ("CPU Load Captures:")
:log info $cpuarray
:log info ("Array Total: $arraytot")
:log info ("Array size: $arraysize of $maxsamples")
:global highavgcpuload
:if ([:len $highavgcpuload] = 0 || $highavgcpuload < $avgcpuload) do={:set highavgcpuload $avgcpuload}
:log info ("CPU Load - Avg: $avgcpuload High: $highavgcpuload")
:if ($avgcpuload >= 95) do={/tool e-mail send to="email@gmail.com" subject=[/system identity get name] from="email@gmail.com" body=([/system identity get name] ,"
   At $time the CPU Load on this router was running at 95%")};

Ovviamente dovete cambiare i due indirizzi email all'interno con quello che volete voi.

Per quanto riguarda invece la programmazione dello scheduler purtroppo non riesco a farlo andare da linea di comando (forse perchè lo script faceva anche riferimento ad una versione vecchia di routeros ? ) ho dovuto quindi impostandolo a mano,
quindi da interfaccia grafica, basta andare in system-->scheduler---->+ e a questo punto si da un nome allo script, si impostano i parametri come da post precedente stando attenti a mettere lo stesso nome dello script che si è creato al punto precedente.

Spero di aver fatto cosa gradita Smile
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Information [Mikrotik] Semi-Automating CPE ROS/Firmware/script updates and setting changes berryberry 0 713 17-06-2015, 11:54
Ultimo messaggio: berryberry
Information [Mikrotik] SXT 5HnD Alignment Script berryberry 0 943 17-06-2015, 11:47
Ultimo messaggio: berryberry
Information [Mikrotik] Yet Another Alignment Script With LEDs And Sound berryberry 0 988 17-06-2015, 11:07
Ultimo messaggio: berryberry
  [Mikrotik] Improved auto upgrade script v3.X berryberry 0 592 17-06-2015, 10:53
Ultimo messaggio: berryberry
Information [Mikrotik] Automated Upgrade/Downgrade script V3.9+ berryberry 0 571 17-06-2015, 10:51
Ultimo messaggio: berryberry
Information [Mikrotik] Auto upgrade script V3.x berryberry 0 368 17-06-2015, 10:34
Ultimo messaggio: berryberry
Information [Mikrotik] Monitor logs, send email alert / run script berryberry 0 717 16-06-2015, 10:55
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience /Monitoring -ECMP Failover Script berryberry 0 531 16-06-2015, 09:45
Ultimo messaggio: berryberry
Information [Mikrotik] Resilience/Monitoring- Monitoring Script berryberry 0 417 16-06-2015, 08:56
Ultimo messaggio: berryberry
Information [Mikrotik] Log Parser - Event Trigger Script berryberry 0 476 11-06-2015, 09:52
Ultimo messaggio: berryberry

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.