Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Un altro esempio di Port Forwarding

#1
Insieme ad un gruppo di amici stiamo attrezzando un ponte ripetitore radioamatoriale che funzioni come gateway D-Star (usando ircDDB e i software ICOM), date le caratteristiche estremamente restrittive dei software Icom ho dovuto usare una RouterBoard per poter ricevere il segnale wifi da una postazione remota (in quanto il ponte ripetitore si troverà in alta montagna), effettuare tutti i NAT necessari e gestire il port forwarding di tutte le porte necessarie al corretto funzionamento:

[hide]
Codice:
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=profile1 \
    supplicant-identity="" wpa-pre-shared-key=xxxxxxxxx \
    wpa2-pre-shared-key=xxxxxxxxx
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g country=italy disabled=no \
    frequency=2437 security-profile=profile1 ssid="yyyyyyy" tx-power=1 \
    tx-power-mode=all-rates-fixed wireless-protocol=unspecified
/ip neighbor discovery
set wlan1 discover=no
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
/ip pool
add name=dhcp ranges=10.0.0.1-10.254.254.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=ether1 lease-time=3d name=dhcp1
/port
set 0 baud-rate=9600
/system logging action
set 0 memory-lines=100
set 1 disk-lines-per-file=100
/ip address
add address=10.0.0.1/8 interface=ether1 network=10.0.0.0
/ip cloud
set ddns-enabled=yes
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=wlan1
/ip dhcp-server network
add address=10.0.0.0/8 dns-server=8.8.8.8 gateway=10.0.0.1 netmask=8
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
#############################################################
# PORT FORWARDING
# le richieste arrivano sulla porta WLAN e vengono reindirizzate sulla ETHER1
#############################################################
/ip firewall nat
add action=masquerade chain=srcnat comment="- - - NAT - - -" out-interface=\
    wlan1 to-addresses=0.0.0.0
add action=dst-nat chain=dstnat comment="Interfaccia Dstar Icom" dst-port=443 \
    in-interface=wlan1 protocol=tcp to-addresses=10.0.0.2 to-ports=443
add action=dst-nat chain=dstnat disabled=yes dst-port=20000-20005 \
    in-interface=wlan1 protocol=tcp to-addresses=10.0.0.2 to-ports=\
    20000-20005
add action=dst-nat chain=dstnat disabled=yes dst-port=20000-20005 \
    in-interface=wlan1 protocol=udp to-addresses=10.0.0.2 to-ports=\
    20000-20005
add action=dst-nat chain=dstnat comment="Dstar A" dst-port=40000 \
    in-interface=wlan1 protocol=udp to-addresses=10.0.0.2 to-ports=40000
add action=dst-nat chain=dstnat comment="Dstar B" dst-port=40001 \
    in-interface=wlan1 protocol=tcp to-addresses=10.0.0.2 to-ports=40001
add action=dst-nat chain=dstnat dst-port=5900 in-interface=wlan1 log=yes \
    protocol=tcp to-addresses=10.0.0.2 to-ports=5900
add action=dst-nat chain=dstnat comment=TCP dst-port=20000 in-interface=wlan1 \
    log=yes protocol=tcp to-addresses=10.0.0.2 to-ports=20000
add action=dst-nat chain=dstnat dst-port=20001 in-interface=wlan1 log=yes \
    protocol=tcp to-addresses=10.0.0.2 to-ports=20001
add action=dst-nat chain=dstnat dst-port=20005 in-interface=wlan1 log=yes \
    protocol=tcp to-addresses=10.0.0.2 to-ports=20005
add action=dst-nat chain=dstnat comment=UDP dst-port=20000 in-interface=wlan1 \
    log=yes protocol=udp to-addresses=10.0.0.2 to-ports=20000
add action=dst-nat chain=dstnat dst-port=20001 in-interface=wlan1 log=yes \
    protocol=udp to-addresses=10.0.0.2 to-ports=20001
add action=dst-nat chain=dstnat dst-port=20002 in-interface=wlan1 log=yes \
    protocol=udp to-addresses=10.0.0.2 to-ports=20002
add action=dst-nat chain=dstnat dst-port=20005 in-interface=wlan1 log=yes \
    protocol=udp to-addresses=10.0.0.2 to-ports=20005
add action=dst-nat chain=dstnat dst-port=20004 in-interface=wlan1 log=yes \
    protocol=udp to-addresses=10.0.0.2 to-ports=20004
add action=dst-nat chain=dstnat dst-port=20003 in-interface=wlan1 log=yes \
    protocol=udp to-addresses=10.0.0.2 to-ports=20003
add action=dst-nat chain=dstnat dst-port=20004 in-interface=wlan1 log=yes \
    protocol=tcp to-addresses=10.0.0.2 to-ports=20004
add action=dst-nat chain=dstnat dst-port=20003 in-interface=wlan1 log=yes \
    protocol=tcp to-addresses=10.0.0.2 to-ports=20003
add action=dst-nat chain=dstnat dst-port=20002 in-interface=wlan1 log=yes \
    protocol=tcp to-addresses=10.0.0.2 to-ports=20002
add action=dst-nat chain=dstnat dst-port=80 in-interface=wlan1 protocol=tcp \
    to-addresses=10.0.0.2 to-ports=80
###########################################################
/ip route
add disabled=yes distance=1 gateway=192.168.1.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www port=8080
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Europe/Rome
/system leds
add interface=wlan1 leds=led1,led2,led3,led4,led5 type=\
    wireless-signal-strength
/system logging
add action=disk topics=error,system,critical,account
/system ntp client
set enabled=yes primary-ntp=193.204.114.232 secondary-ntp=193.204.114.233
[/hide]
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  [Mikrotik] Proteggere la routerboard dal port scan hamtarociaoo 16 4'211 12-05-2016, 10:30
Ultimo messaggio: dancollins
Bug un altro esempio di configurazione del firewall hamtarociaoo 23 4'661 06-02-2015, 08:15
Ultimo messaggio: kikko
  Esempio sulla configurazione del firewall di RouterOS kikko 23 7'675 22-02-2014, 16:57
Ultimo messaggio: kikko

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.