Facebook  -  Twitter      

Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
un altro esempio di configurazione del firewall

#1
Bug 
Ecco un altro esempio di configurazione del firewall prelevato dalla RouterBoard demo messa a disposizione dalla Mikrotik
[hide]

Codice:
/ip firewall filter
add chain=input comment="Established connections" connection-state=established
add chain=input comment="Related connections" connection-state=related
add action=log chain=input comment="Log invalid connections" connection-state=invalid log-prefix=INVALID
add action=drop chain=input comment="Drop invalid connections" connection-state=invalid
add action=jump chain=input comment="!!! Check for well-known viruses !!!" jump-target=virus add chain=input comment=UDP protocol=udp add chain=input comment=ICMP protocol=icmp
add chain=input comment="Allow PPTP" dst-port=1723 protocol=tcp add chain=input comment="Allow PPTP" protocol=gre
add chain=input comment="Allow OSPF" protocol=ospf add action=jump chain=input comment="Jump to demo chain" jump-target=demo
add chain=input comment="Allow from Dude Server" src-address=159.148.147.209
add chain=input comment="From local net" src-address=10.0.0.0/8 add action=log chain=input comment="Log everything else" log-prefix=DROP
add action=drop chain=input comment="Drop everything else" add chain=forward comment="Established connections" connection-state=established
add chain=forward comment="Related connections" connection-state=related
add action=log chain=forward comment="Log invalid connections" connection-state=invalid log-prefix=INVALID
add action=drop chain=forward comment="Drop invalid connections" connection-state=invalid
add action=jump chain=forward comment="!!! Check for well-known viruses !!!" jump-target=virus
add chain=forward comment=UDP protocol=udp add chain=forward comment=ICMP protocol=icmp
add chain=customer comment="From local net" src-address=10.0.0.0/8
add action=log chain=customer comment="Log everything else" log-prefix=DROP
add action=drop chain=customer comment="Drop everything else"
add action=drop chain=virus comment="Drop Blaster Worm" dst-port=135-139 protocol=tcp
add action=drop chain=virus comment="Drop Messenger Worm" dst-port=135-139 protocol=udp
add action=drop chain=virus comment="Drop Blaster Worm" dst-port=445 protocol=tcp
add action=drop chain=virus comment="Drop Blaster Worm" dst-port=445 protocol=udp
add action=drop chain=virus comment=________ dst-port=593 protocol=tcp
add action=drop chain=virus comment="Drop MyDoom" dst-port=1080 protocol=tcp
add action=drop chain=virus comment=________ dst-port=1214 protocol=tcp
add action=drop chain=virus comment="ndm requester" dst-port=1363 protocol=tcp
add action=drop chain=virus comment="ndm server" dst-port=1364 protocol=tcp
add action=drop chain=virus comment="screen cast" dst-port=1368 protocol=tcp
add action=drop chain=virus comment=hromgrafx dst-port=1373 protocol=tcp
add action=drop chain=virus comment=cichlid dst-port=1377 protocol=tcp
add action=drop chain=virus comment=Worm dst-port=1433-1434 protocol=tcp
add action=drop chain=virus comment="Bagle Virus" dst-port=2745 protocol=tcp
add action=drop chain=virus comment="Drop Dumaru.Y" dst-port=2283 protocol=tcp
add action=drop chain=virus comment="Drop Beagle.C-K" dst-port=2745 protocol=tcp
add action=drop chain=virus comment="Drop MyDoom" dst-port=3127-3128 protocol=tcp
add action=drop chain=virus comment="Drop Backdoor OptixPro" dst-port=3410 protocol=tcp
add action=drop chain=virus comment=Worm dst-port=4444 protocol=tcp
add action=drop chain=virus comment=Worm dst-port=4444 protocol=udp
add action=drop chain=virus comment="Drop Sasser" dst-port=5554 protocol=tcp
add action=drop chain=virus comment="Drop Beagle.B" dst-port=8866 protocol=tcp
add action=drop chain=virus comment="Drop Dabber.A-B" dst-port=9898 protocol=tcp
add action=drop chain=virus comment="Drop Dumaru.Y" dst-port=10000 protocol=tcp
add action=drop chain=virus comment="Drop MyDoom.B" dst-port=10080 protocol=tcp
add action=drop chain=virus comment="Drop NetBus" dst-port=12345 protocol=tcp
add action=drop chain=virus comment="Drop Kuang2" dst-port=17300 protocol=tcp
add action=drop chain=virus comment="Drop SubSeven" dst-port=27374 protocol=tcp
add action=drop chain=virus comment="Drop PhatBot, Agobot, Gaobot" dst-port=65506 protocol=tcp
add chain=demo comment="Allow WinBox for demo purposes" dst-port=8291 protocol=tcp
add chain=demo comment="Allow Web for demo purposes" dst-port=80 protocol=tcp
add chain=demo comment="Allow Telnet for demo purposes" dst-port=23 protocol=tcp
add chain=demo comment="Allow SSH for demo purposes" dst-port=22 protocol=tcp
add chain=demo comment="Allow FTP for demo purposes" dst-port=21 protocol=tcp
add chain=demo comment="Allow APISSL for demo purposes" dst-port=8729 protocol=tcp
add action=jump chain=forward comment="Protect the Customer" jump-target=customer out-interface=ether2
add action=jump chain=forward comment="Protect the Customer" jump-target=customer out-interface=ether3
add chain=forward comment="Everything else allow pass through"
[/hide]
Cita messaggio

#2
scusatemi, qualcuno mi puo' spiegare che funzione ha la voce chain=virus ?
non capisco il senso, cosi non funzionera' mai quella regola, o sbaglio ?
Cita messaggio

#3
come ben saprai i trojan girano su alcune pote specifiche .......
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#4
Scusami , forse mi sono espresso male io o mi sfugge qualcosa , mi riferisco alla sezione chain- c'è scritto virus, non dovrebbe esserci input , out , ecc ecc , non capisco perché c'è scritto virus
Cita messaggio

#5
(03-02-2015, 11:03)ciccioprofuma Ha scritto: Scusami , forse mi sono espresso male io o mi sfugge qualcosa , mi riferisco alla sezione chain- c'è scritto virus, non dovrebbe esserci input , out , ecc ecc , non capisco perché c'è scritto virus

è una definizione
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#6
Ok, si era capito, ma lasciandolo in quel modo la regola non funzionerà mai
Cita messaggio

#7
onestamente non saprei la devo provare ma mi sembra che a me vada tutto bene
MTCNA Certified
MTCRE Certified
------------------------------
www.routerositalia.it
www.ubntitalia.it
Cita messaggio

#8
Mi sembra impossibile che funziona lasciando scritto virus, non ha un senso logico, cosa prenderà così il chain come riferimento, non sa se bloccare le connessioni in entrata , uscita o di forw
Cita messaggio

#9
definendola virus ha creato un nuovo riferimento che non appartiene a nessuna delle categorie, dal wiki infatti leggiamo:

Codice:
Specifies to which chain rule will be added. If the input does not match the name of an already defined chain, a new chain will be created.

cioè se usi una chain che non esiste in quel momento viene aggiunta con le caratteristiche richieste dalla regola, in questo caso tutte le regole che hanno come oggetto "virus" vengono bloccate.

ti assicuro per esperienza personale che il tutto funziona, se hai altri dubbi prova a creare una regola con "chain=virus" e imposta la porta che vuoi bloccare su 443 e vedrai che tutte le pagine in https non funzioneranno
Cita messaggio

#10
Ti assicuro che ho provato e non funziona, se invece metto in o out o forw , funziona, chiaramente in base alla chain che scelgo
Cita messaggio


[-]
Condividi/Segnala (Mostra tutti)
Facebook Linkedin Twitter

Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  [Mikrotik] Basic Firewall hamtarociaoo 21 8'087 16-08-2016, 15:47
Ultimo messaggio: tecnofan
  Un altro esempio di Port Forwarding hamtarociaoo 0 839 22-11-2015, 18:11
Ultimo messaggio: hamtarociaoo
  Esempio sulla configurazione del firewall di RouterOS kikko 23 7'675 22-02-2014, 16:57
Ultimo messaggio: kikko
  [Mikrotik] Firewall: Mangle hamtarociaoo 17 10'059 27-09-2013, 16:28
Ultimo messaggio: kikko
  [Mikrotik] Firewall: Address List hamtarociaoo 0 1'956 12-09-2013, 18:44
Ultimo messaggio: hamtarociaoo
  [Mikrotik] Firewall: Layer 7 hamtarociaoo 0 1'903 12-09-2013, 18:43
Ultimo messaggio: hamtarociaoo
  [Mikrotik] Firewall: Connection tracking hamtarociaoo 0 3'719 12-09-2013, 18:42
Ultimo messaggio: hamtarociaoo
Information [Mikrotik] RouterOS: il firewall hamtarociaoo 0 4'125 12-09-2013, 18:34
Ultimo messaggio: hamtarociaoo

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2017 MyBB Group.