RouterOS Italia

Versione completa: Guida: Blocco pubblicità con Web Proxy
Al momento stai visualizzando i contenuti in una versione ridotta. Visualizza la versione completa e formattata.
In questa guida vi mostro come alleggerire le pagine web da tutte quelle fastidiose pubblicità che infestano la rete ed eventualmente bloccare l'accesso a determinati siti, il tutto sfruttando le potenzialità di WebProxy di RouterOS:

[hide]
abilitiamo il proxy:

Codice:
/ip proxy
set cache-administrator=webmaster cache-path=web-proxy1 \
    enabled=yes max-cache-size=8192KiB

rendiamolo trasparente (deve gestire qualunque richiesta e non essere notato dagli utenti)

Codice:
/ip firewall nat
add action=redirect chain=dstnat dst-port=80 protocol=tcp to-ports=8080

ora aggiungiamo qualche sito da bloccare (nell'elenco ho inserito alcuni esempi di siti contenenti malware e pubblicità, potete personalizzarlo a vostro piacimento)

Codice:
/ip proxy access
add dst-host=:routerositalia
add dst-address=192.168.1.0/24 comment="accesso a tutti gli ip della lan"
add action=deny src-address=!192.168.1.0/24 comment="blocco di tutti gli ip estranei alla rete"
add dst-host=:facebook comment="accesso a facebook consentito"
add action=deny comment="Indirizzi Bloccati" dst-host=:softonic
add action=deny dst-host=:banner
add action=deny dst-host=:ads
add action=deny dst-host=:advert
add action=deny dst-host=:delta-search
add action=deny dst-host=:searchmania
add action=deny dst-host=:genieo
add action=deny dst-host=:pagead2
add action=deny dst-host=:ilivid
add action=deny dst-host=:popup
add action=deny dst-host=:politics-europe
add action=deny dst-host=:nebridalguide
add action=deny dst-host=:freestat
add action=deny dst-host=www.3000.ws
add action=deny dst-host=:dollars
add action=deny dst-host=:ahacash
add action=deny dst-host=www.bestwebslinks.com
add action=deny dst-host=:cash
add action=deny dst-host=www.finecobanca.net
add action=deny dst-host=www.komp3.net
add action=deny dst-host=www.sellhotter.com
add action=deny dst-host=www.ysbweb.com
add action=deny dst-host=:dex1
add action=deny dst-host=www.replicadiorologi.com
add action=deny dst-host=:outletgrandifirme
add action=deny dst-host=:melascrivi
add action=deny dst-host=:yourfinancecim
add action=deny dst-host=:ukashexchange
add action=deny dst-host=:wufada
add action=deny dst-host=:stock-elettronica
[/hide]

ora potete sbizzarrirvi a personalizzare la lista e navigare sempre più sicuri!
Il problema è il carico sulla RouterBoard a livello di Ram e Cpu e l'affidabilità stessa del webproxy.
Consiglio di usarlo con sistemi x86 e schedulare un riavvio della RouterBoard ogni 1-2 giorni.
Sistema ottimo anche per bloccare l'accesso a siti porno e altro.
Basta fare regole tipo:
add action=deny dst-host=*adult*
oppure
add action=deny dst-host=*xxx*
Io lo uso a livello domestico... Dove ci sono al massimo 4-5 dispositivi connessi e ogni sera la routerboard viene riavviata... Su una RB951G non ho riscontrato alcun problema