RouterOS Italia

Versione completa: [Mikrotik] A Bit of Sounds
Al momento stai visualizzando i contenuti in una versione ridotta. Visualizza la versione completa e formattata.
Part One: SQUAWK
The scripts below are based on SQUAWK program © 1987 Merlin R. Null.
SQUAWK Chang

Codice:
:for j from=1 to=4 step=1 do={
  :for i from=2000 to=50 step=-400 do={
    :beep frequency=$i length=11ms;
    :delay 11ms;
  }
  :for i from=800 to=2000 step=400 do={
    :beep frequency=$i length=11ms;
    :delay 11ms;
  }
}
SQUAWK Coo

Codice:
:for i from=0 to=150 step=10 do={

Codice:
  :beep frequency=(1295 - i) length=22ms;

Codice:
  :delay 22ms;

Codice:
  :beep frequency=(1095 + i) length=22ms;

Codice:
  :delay 22ms;

Codice:
}


SQUAWK Oh!

Codice:
:for i from=800 to=2000 step=100 do={

Codice:
  :beep frequency=$i length=11ms;

Codice:
  :delay 11ms;

Codice:
}

Codice:
:for i from=2000 to=50 step=-100 do={

Codice:
  :beep frequency=$i length=11ms;

Codice:
  :delay 11ms;

Codice:
}


SQUAWK Phone 1

Codice:
:for i from=1 to=10 step=1 do={

Codice:
  :beep frequency=1195 length=22ms;

Codice:
  :delay 22ms;

Codice:
  :beep frequency=2571 length=22ms;

Codice:
  :delay 22ms;

Codice:
}


SQUAWK Siren

Codice:
:for i from=1 to=3 step=1 do={

Codice:
  :beep frequency=550 length=494ms;

Codice:
  :delay 494ms;

Codice:
  :beep frequency=400 length=494ms;

Codice:
  :delay 494ms;

Codice:
}


SQUAWK Space 1

Codice:
:for i from=1000 to=40 step=-20 do={

Codice:
  :beep frequency=$i length=11ms;

Codice:
  :delay 11ms;

Codice:
}


SQUAWK Space 2

Codice:
:for i from=10000 to=500 step=-500 do={

Codice:
  :beep frequency=$i length=11ms;

Codice:
  :delay 11ms;

Codice:
}


Phone Call

Codice:
:for i from=1 to=10 do={

Codice:
  /system script run "SQUAWK Phone 1";

Codice:
  :delay 400ms;

Codice:
  /system script run "SQUAWK Phone 1";

Codice:
  :delay 2000ms;


Part Two: Adams
The scripts below are based on the code from Lee Adams' book "Grafik, Animation, Simulation fur Personalcomputer" (ISBN 3890905722, Markt&Technik, 1989).
Adams Fanfare
Codice:
:for t from=1200 to=350 step=-50 do={

Codice:
  :beep frequency=$t length=33ms;

Codice:
  :delay 33ms;

Codice:
}


Adams Larm

Codice:
:for t1 from=1 to=10 step=1 do={

Codice:
  :for t2 from=300 to=1800 step=40 do={

Codice:
    :beep frequency=$t2 length=11ms;

Codice:
    :delay 11ms;

Codice:
  }

Codice:
}


Adams Maschinengewehr

Codice:
:for t from=1 to=20 step=1 do={

Codice:
  :beep frequency=40 length=33ms;

Codice:
  :delay 33ms;

Codice:
  :delay 55ms;

Codice:
}


Adams Telefone

Codice:
:for t1 from=1 to=4 step=1 do={

Codice:
  :for t2 from=1 to=25 step=1 do={

Codice:
    :beep frequency=540 length=33ms;

Codice:
    :delay 33ms;

Codice:
    :beep frequency=650 length=27ms;

Codice:
    :delay 27ms;

Codice:
  }

Codice:
  :delay 2000ms;

Codice:
}


Adams Tonarkade

Codice:
:for t1 from=1 to=8 step=1 do={

Codice:
    :for t2 from=600 to=750 step=8 do={

Codice:
    :beep frequency=$t2 length=11ms;

Codice:
    :delay 11ms;

Codice:
  }

Codice:
}


Adams Tonarkade 2

Codice:
:for t from=1250 to=600 step=-8 do={

Codice:
  :beep frequency=$t length=11ms;

Codice:
  :delay 11ms;

Codice:
}


Part Three: Miklavcic
The scripts below are based on the code from http://snipplr[url=http://snipplr.com/view/9220/simple-tic-tac-toe/][/url].com /view/9220/simple -tic-tac-toe/
Miklavcic Sad
Codice:
:beep frequency=784 length=500ms;

Codice:
:delay 500ms;


Codice:
:beep frequency=738 length=500ms;

Codice:
:delay 500ms;


Codice:
:beep frequency=684 length=500ms;

Codice:
:delay 500ms;


Codice:
:beep frequency=644 length=1000ms;

Codice:
:delay 1000ms;


Miklavcic Victory

Codice:
:beep frequency=523 length=200ms;

Codice:
:delay 1000ms;


Codice:
:beep frequency=523 length=200ms;

Codice:
:delay 1000ms;


Codice:
:beep frequency=523 length=200ms;

Codice:
:delay 1000ms;


Codice:
:beep frequency=659 length=700ms;

Codice:
:delay 700ms;


Codice:
:beep frequency=784 length=500ms;

Codice:
:delay 500ms;


Codice:
:beep frequency=523 length=200ms;

Codice:
:delay 1000ms;


Codice:
:beep frequency=523 length=200ms;

Codice:
:delay 1000ms;


Codice:
:beep frequency=523 length=200ms;

Codice:
:delay 1000ms;


Codice:
:beep frequency=659 length=700ms;

Codice:
:delay 700ms;


Codice:
:beep frequency=784 length=500ms;

Codice:
:delay 800ms;


Codice:
:beep frequency=784 length=400ms;

Codice:
:delay 400ms;


Codice:
:beep frequency=884 length=200ms;

Codice:
:delay 200ms;


Codice:
:beep frequency=784 length=200ms;

Codice:
:delay 200ms;


Codice:
:beep frequency=687 length=200ms;

Codice:
:delay 200ms;


Codice:
:beep frequency=659 length=200ms;

Codice:
:delay 200ms;


Codice:
:beep frequency=579 length=200ms;

Codice:
:delay 200ms;


Codice:
:beep frequency=519 length=400ms;

Codice:
:delay 400ms;


Part Z: Assorted Sounds

Sound 1

Codice:
:beep frequency=600 length=165ms;

Codice:
:delay 165ms;


Codice:
:beep frequency=50 length=83ms;

Codice:
:delay 83ms;


Codice:
:beep frequency=600 length=165ms;

Codice:
:delay 165ms;


Codice:
:beep frequency=50 length=83ms;

Codice:
:delay 83ms;


Codice:
:beep frequency=650 length=165ms;

Codice:
:delay 165ms;


Codice:
:beep frequency=600 length=165ms;

Codice:
:delay 165ms;


Codice:
:beep frequency=50 length=83ms;

Codice:
:delay 83ms;


Codice:
:beep frequency=600 length=165ms;

Codice:
:delay 165ms;


Codice:
:beep frequency=700 length=275ms;

Codice:
:delay 275ms;


Codice:
:beep frequency=800 length=275ms;

Codice:
:delay 275ms;


Codice:
:beep frequency=900 length=110ms;

Codice:
:delay 110ms;