Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Guida: Blocco pubblicità con Web Proxy

#1
In questa guida vi mostro come alleggerire le pagine web da tutte quelle fastidiose pubblicità che infestano la rete ed eventualmente bloccare l'accesso a determinati siti, il tutto sfruttando le potenzialità di WebProxy di RouterOS:

[hide]
abilitiamo il proxy:

Codice:
/ip proxy
set cache-administrator=webmaster cache-path=web-proxy1 \
    enabled=yes max-cache-size=8192KiB

rendiamolo trasparente (deve gestire qualunque richiesta e non essere notato dagli utenti)

Codice:
/ip firewall nat
add action=redirect chain=dstnat dst-port=80 protocol=tcp to-ports=8080

ora aggiungiamo qualche sito da bloccare (nell'elenco ho inserito alcuni esempi di siti contenenti malware e pubblicità, potete personalizzarlo a vostro piacimento)

Codice:
/ip proxy access
add dst-host=:routerositalia
add dst-address=192.168.1.0/24 comment="accesso a tutti gli ip della lan"
add action=deny src-address=!192.168.1.0/24 comment="blocco di tutti gli ip estranei alla rete"
add dst-host=:facebook comment="accesso a facebook consentito"
add action=deny comment="Indirizzi Bloccati" dst-host=:softonic
add action=deny dst-host=:banner
add action=deny dst-host=:ads
add action=deny dst-host=:advert
add action=deny dst-host=:delta-search
add action=deny dst-host=:searchmania
add action=deny dst-host=:genieo
add action=deny dst-host=:pagead2
add action=deny dst-host=:ilivid
add action=deny dst-host=:popup
add action=deny dst-host=:politics-europe
add action=deny dst-host=:nebridalguide
add action=deny dst-host=:freestat
add action=deny dst-host=www.3000.ws
add action=deny dst-host=:dollars
add action=deny dst-host=:ahacash
add action=deny dst-host=www.bestwebslinks.com
add action=deny dst-host=:cash
add action=deny dst-host=www.finecobanca.net
add action=deny dst-host=www.komp3.net
add action=deny dst-host=www.sellhotter.com
add action=deny dst-host=www.ysbweb.com
add action=deny dst-host=:dex1
add action=deny dst-host=www.replicadiorologi.com
add action=deny dst-host=:outletgrandifirme
add action=deny dst-host=:melascrivi
add action=deny dst-host=:yourfinancecim
add action=deny dst-host=:ukashexchange
add action=deny dst-host=:wufada
add action=deny dst-host=:stock-elettronica
[/hide]

ora potete sbizzarrirvi a personalizzare la lista e navigare sempre più sicuri!
Cita messaggio

#2
Il problema è il carico sulla RouterBoard a livello di Ram e Cpu e l'affidabilità stessa del webproxy.
Consiglio di usarlo con sistemi x86 e schedulare un riavvio della RouterBoard ogni 1-2 giorni.
Sistema ottimo anche per bloccare l'accesso a siti porno e altro.
Basta fare regole tipo:
add action=deny dst-host=*adult*
oppure
add action=deny dst-host=*xxx*
Cita messaggio

#3
Io lo uso a livello domestico... Dove ci sono al massimo 4-5 dispositivi connessi e ogni sera la routerboard viene riavviata... Su una RB951G non ho riscontrato alcun problema
Cita messaggio


Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
  Guida creazione VPN PPTP con RouterOS mannana93 61 27'320 10-05-2018, 16:19
Ultimo messaggio: FabioPisa
  Guida al logging delle connessioni con RouterOS mannana93 5 4'115 26-07-2016, 06:50
Ultimo messaggio: kikko
  Guida: Internet Key su RouterOS hamtarociaoo 16 11'251 05-12-2015, 18:20
Ultimo messaggio: nirinny
  Guida: QoS hamtarociaoo 52 24'005 14-11-2015, 08:13
Ultimo messaggio: kikko
  Guida - Condivisione con protoc. SAMBA di un archivio di massa USB collegato alla RouterBoard mannana93 161 37'008 23-07-2015, 14:58
Ultimo messaggio: giallopaperino
  Guida: Creare una rete per gli ospiti hamtarociaoo 22 10'134 14-06-2015, 22:45
Ultimo messaggio: kikko
  Guida: Link a lunga distanza con PPPoE e nstreme hamtarociaoo 10 5'728 22-05-2015, 05:58
Ultimo messaggio: kikko
  Guida VPN L2TP/IPsec mannana93 59 24'482 02-02-2015, 15:38
Ultimo messaggio: hamtarociaoo
  Guida: Sincronizzare l'orologio (tramite NTP) hamtarociaoo 19 6'908 23-10-2014, 21:25
Ultimo messaggio: giallopaperino
  Guida: Aggiornare una RouterBoard senza seriale (RB711-5HN) con Netinstall hamtarociaoo 3 3'786 22-10-2014, 19:17
Ultimo messaggio: kikko

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2019 MyBB Group.