Questo forum fa uso dei cookie
Questo forum utilizza i cookie per memorizzare i dettagli del tuo login o della tua ultima visita. I cookie sono piccoli files di testo salvati nel computer; i cookie da noi utilizzati sono relativi unicamente ai servizi da noi forniti direttamente o dai banner pubblicitari. I cookie su questo forum salvano inoltre i dettagli relativi alle discussioni lette e alle tue preferenze personali. Sei pregato di selezionare il tasto OKAY se sei consapevole della presenza di questi files e ci autorizzi ad utilizarli per le informazioni specificate.

Indipendentemente dalla tua scelta un cookie verrà salvato per memorizzare nel tuo pc la risposta a questo form. Puoi modificare le impostazioni relative ai cookie nelle preferenze del tuo browser.

  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[Mikrotik] Send email about reboot

#1
Information 
This script is meant for being run on router startup (using scheduler). Script sends an email with time of router reboot and entire log once 90 seconds have been passed since initial time synchronization from NTP. Besides event about reboot is logged once time has been synchronized from NTP.
Codice:
:while ( [/system ntp client get status]!="synchronized" ) do={ :delay 10s }

Codice:
:delay 10s

Codice:
/log info "time updated; uptime: $[/system resource get uptime]"

Codice:
:local es "$[/system identity get name] rebooted on $[/system clock get date] $[/system clock get time] uptime $[/system resource get uptime]"

Codice:
:delay 90s

Codice:
:local eb "Log contents (with 90 seconds delay):\r\n"

Codice:
:foreach le in=[/log print as-value] do={

Codice:
 :set eb ($eb.[:tostr [($le->"time")]]." ".[:tostr [($le->"topics")]].": ".[:tostr [($le->"message")]]."\r\n")

Codice:
}

Codice:
/tool e-mail send to="enter_your_email_here@example.com" subject=$es body=$eb


This script helps to keep track of router reboots (e.g. of reboots caused by power interruptions).
This script requires NTP package (from All packages download).
NB Script has not been tested with logging to disk enabled. In case time synchronization is not available after reboot, the script will send e-mail once the time is synchronized (date and time in subject will be from the moment of time synchronization and not from the moment of reboot).
Old (22 September 2013) version, not requiring NTP package and working only on pre-6.16 versions of RouterOS, is available here .[url=http://wiki.mikrotik.com/index.php?title=Send_email_about_reboot&oldid=25733][/url]
Cita messaggio


Discussioni simili
Discussione Autore Risposte Letto Ultimo messaggio
Information [Mikrotik] Reboot Boards due to low Memory with notification berryberry 0 941 17-06-2015, 11:03
Ultimo messaggio: berryberry
Information [Mikrotik] Send Backup email berryberry 0 997 16-06-2015, 12:26
Ultimo messaggio: berryberry
Information [Mikrotik] Centralized Automated Backups via Email with Procmail and Perl berryberry 0 848 16-06-2015, 11:49
Ultimo messaggio: berryberry
Information [Mikrotik] Monitor logs, send email alert / run script berryberry 0 1'247 16-06-2015, 10:55
Ultimo messaggio: berryberry
Information [Mikrotik] Email setup/troubleshooting berryberry 0 666 09-06-2015, 09:54
Ultimo messaggio: berryberry
  Backup RouterOS per email kikko 0 1'152 13-06-2013, 14:34
Ultimo messaggio: kikko
Exclamation Primo step: Email setup kikko 0 1'789 13-06-2013, 13:41
Ultimo messaggio: kikko

Digg   Delicious   Reddit   Facebook   Twitter   StumbleUpon  


Utenti che stanno guardando questa discussione:
1 Ospite(i)


Powered by MyBB, © 2002-2019 MyBB Group.